aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2010-01-18 08:42:48 +0100
committerSebastian Hahn <sebastian@torproject.org>2010-01-27 12:13:10 +0100
commit2fc0c3031bc48630382c959b9b3ec1306305333f (patch)
treef807f8622b0d6e21c860ab6cd7dee79616cd3b46 /doc/Makefile.am
parent9fe1c000b0b1a91acf605ef71a538da7b7218fe9 (diff)
downloadtor-2fc0c3031bc48630382c959b9b3ec1306305333f.tar
tor-2fc0c3031bc48630382c959b9b3ec1306305333f.tar.gz
Convert the tor-gencert manpage to asciidoc
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 2eae7a187..4810d2538 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -5,12 +5,12 @@ html_in = $(asciidoc_files:=.html.in)
man_in = $(asciidoc_files:=.1.in)
EXTRA_DIST = HACKING \
- tor-resolve.1 tor-gencert.1 \
+ tor-resolve.1 \
$(html_in) $(man_in) $(asciidoc_files:=.1.txt) \
tor-osx-dmg-creation.txt tor-rpm-creation.txt \
tor-win32-mingw-creation.txt torify.1
-nodist_man_MANS = tor.1 tor-resolve.1 tor-gencert.1 torify.1 $(asciidoc_files:=.1)
+nodist_man_MANS = tor.1 tor-resolve.1 torify.1 $(asciidoc_files:=.1)
doc_DATA = $(asciidoc_files:=.html)
@@ -25,12 +25,19 @@ DIST_SUBDIRS = design-paper spec
$(html_in) :
$(top_srcdir)/doc/asciidoc-helper.sh html @ASCIIDOC@ @SED@ $@
+tor-gencert.html.in : tor-gencert.1.txt
+
# Generate the manpage from asciidoc, but don't do
# machine-specific replacements yet
$(man_in) :
$(top_srcdir)/doc/asciidoc-helper.sh man @A2X@ @SED@ $@
+tor-gencert.1.in : tor-gencert.1.txt
+
# use ../config.status to swap all machine-specific magic strings
# in the asciidoc with their replacements.
$(asciidoc_product) :
../config.status --file=$@;
+
+tor-gencert.1 : tor-gencert.1.in
+tor-gencert.html : tor-gencert.html.in