aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2010-01-20 23:32:27 -0500
committerSebastian Hahn <sebastian@torproject.org>2010-01-27 12:13:10 +0100
commit0c81d4c62b9f18f6b4ee44e9e2552b7e9911fb51 (patch)
tree910aff12d60bcf141ff266b0aac410b127dc669f /doc/Makefile.am
parent1a3f42d1d01b2cde2b3fa1d7df10e71d52a784ea (diff)
downloadtor-0c81d4c62b9f18f6b4ee44e9e2552b7e9911fb51.tar
tor-0c81d4c62b9f18f6b4ee44e9e2552b7e9911fb51.tar.gz
Make the asciidoc build process work from outside top_srcdir
Edited a little by Sebastian
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 25d0a64b2..8619c6f94 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -22,7 +22,7 @@ DIST_SUBDIRS = design-paper spec
# Generate the html documentation from asciidoc, but don't do
# machine-specific replacements yet
$(html_in) :
- $(top_srcdir)/doc/asciidoc-helper.sh html @ASCIIDOC@ @SED@ $@
+ $(top_srcdir)/doc/asciidoc-helper.sh html @ASCIIDOC@ @SED@ $(top_srcdir)/doc/$@
tor.html.in : tor.1.txt
torify.html.in : torify.1.txt
@@ -32,7 +32,7 @@ tor-resolve.html.in : tor-resolve.1.txt
# Generate the manpage from asciidoc, but don't do
# machine-specific replacements yet
$(man_in) :
- $(top_srcdir)/doc/asciidoc-helper.sh man @A2X@ @SED@ $@
+ $(top_srcdir)/doc/asciidoc-helper.sh man @A2X@ @SED@ $(top_srcdir)/doc/$@
tor.1.in : tor.1.txt
torify.1.in : torify.1.txt
@@ -42,6 +42,9 @@ tor-resolve.1.in : tor-resolve.1.txt
# use ../config.status to swap all machine-specific magic strings
# in the asciidoc with their replacements.
$(asciidoc_product) :
+ if test -e $(top_srcdir)/doc/$@.in && ! test -e ./$@.in ; then \
+ cp $(top_srcdir)/doc/$@.in .; \
+ fi
../config.status --file=$@;
tor.1 : tor.1.in