aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorPeter Palfrader <peter@palfrader.org>2006-01-23 15:04:03 +0000
committerPeter Palfrader <peter@palfrader.org>2006-01-23 15:04:03 +0000
commit5521b5de3ee5f505ae07e6e129e1d4a87a87d198 (patch)
tree5c044884cd6544c0920e6398d082a87c83ebbf98 /debian
parent979c71632d2392edc96a1a91040179b6f8636ec9 (diff)
downloadtor-5521b5de3ee5f505ae07e6e129e1d4a87a87d198.tar
tor-5521b5de3ee5f505ae07e6e129e1d4a87a87d198.tar.gz
Print that we're raising the ulimit to stdout in the init script.
svn:r5853
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog3
-rw-r--r--debian/tor.init11
2 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 1e75935f1..debb47b7e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,8 +6,9 @@ tor (0.1.1.12-alpha-cvs-0) unreleased; urgency=low
* Create /var/run/tor on init script start if it does
not exist already.
* Set default ulimit -n to 8k instead of 4k in /etc/default/tor.
+ * Print that we're raising the ulimit to stdout in the init script.
- -- Peter Palfrader <weasel@debian.org> Mon, 23 Jan 2006 15:00:53 +0100
+ -- Peter Palfrader <weasel@debian.org> Mon, 23 Jan 2006 15:57:59 +0100
tor (0.1.1.12-alpha-1) experimental; urgency=low
diff --git a/debian/tor.init b/debian/tor.init
index d764fb942..e930b496f 100644
--- a/debian/tor.init
+++ b/debian/tor.init
@@ -25,7 +25,7 @@ TORPID=$TORPIDDIR/tor.pid
DEFAULTSFILE=/etc/default/$NAME
WAITFORDAEMON=60
ARGS=""
-MAX_FILEDESCRIPTORS=4096
+MAX_FILEDESCRIPTORS=8192
NICE=""
test -x $DAEMON || exit 0
@@ -72,8 +72,15 @@ case "$1" in
fi
if test ! -x $TORPIDDIR; then echo "Cannot access $TORPIDDIR directory, are you root?" >&2; exit 1;
else
+ if [ -n "$MAX_FILEDESCRIPTORS" ]; then
+ echo -n "Raising maximum number of filedescriptors (ulimit -n) to $MAX_FILEDESCRIPTORS"
+ if ulimit -n "$MAX_FILEDESCRIPTORS" ; then
+ echo "."
+ else
+ echo ": FAILED."
+ fi
+ fi
echo "Starting $DESC: $NAME..."
- ulimit -n $MAX_FILEDESCRIPTORS || echo "Warn: Could not set ulimit for number of file descriptors." >&2
start-stop-daemon --start --quiet --oknodo \
--chuid debian-tor:debian-tor \
--pidfile $TORPID \