aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2010-10-11 19:00:43 +0200
committerSebastian Hahn <sebastian@torproject.org>2010-10-11 19:24:25 +0200
commitf3d000f49662f7b3d94340f30fd745c58712ea2b (patch)
treef60fbc188fc316255eb9178ac61afc66f8b40080 /configure.in
parent3d6e2830876c53edcb0f32599929bdb8a069b61e (diff)
downloadtor-f3d000f49662f7b3d94340f30fd745c58712ea2b.tar
tor-f3d000f49662f7b3d94340f30fd745c58712ea2b.tar.gz
Fix MIPSpro and time_t signedness detection
3d6e2830876 silenced the autogen.sh warnings as it was supposed to, but introduced two bugs. Fix them.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 5198ab753..891daa82c 100644
--- a/configure.in
+++ b/configure.in
@@ -199,9 +199,9 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(, [
#error
return x(y);
#endif
-]),
+])],
bmipspro=false; AC_MSG_RESULT(no),
-bmipspro=true; AC_MSG_RESULT(yes)])
+bmipspro=true; AC_MSG_RESULT(yes))
if test "$bmipspro" = true; then
CFLAGS="$CFLAGS -c99"
@@ -575,8 +575,8 @@ AC_RUN_IFELSE([AC_LANG_SOURCE([
#ifdef HAVE_TIME_H
#include <time.h>
#endif
-int main(int c, char**v) { if (((time_t)-1)<0) return 1; else return 0; }]),
- tor_cv_time_t_signed=no, tor_cv_time_t_signed=yes, tor_cv_time_t_signed=cross])
+int main(int c, char**v) { if (((time_t)-1)<0) return 1; else return 0; }])],
+ tor_cv_time_t_signed=no, tor_cv_time_t_signed=yes, tor_cv_time_t_signed=cross)
])
if test "$tor_cv_time_t_signed" = cross; then