aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2006-10-10 23:46:51 +0000
committerNick Mathewson <nickm@torproject.org>2006-10-10 23:46:51 +0000
commitedbda1c1266a5b89d8330b748d6eff747640af9f (patch)
tree285667f07a5e7960ffc6274b7e3d4c28b67c0ede /configure.in
parent93b9209e5972c3052eedc9da9a38e6d872e373c4 (diff)
downloadtor-edbda1c1266a5b89d8330b748d6eff747640af9f.tar
tor-edbda1c1266a5b89d8330b748d6eff747640af9f.tar.gz
r8987@totoro: nickm | 2006-10-10 19:46:08 -0400
Remove -Winline from standard list, add -Wswitch-enum. svn:r8687
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 31200e05d..4774192c5 100644
--- a/configure.in
+++ b/configure.in
@@ -771,17 +771,22 @@ fi
# Add some more warnings which we use in the cvs version but not in the
# released versions. (Some relevant gcc versions can't handle these.)
if test x$enable_gcc_warnings = xyes; then
+
AC_TRY_COMPILE([], [
#if !defined(__GNUC__) || (__GNUC__ < 4)
#error
#endif], have_gcc4=yes, have_gcc4=no)
- CFLAGS="$CFLAGS -W -Wfloat-equal -Wundef -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -Wredundant-decls -Wchar-subscripts -Wcomment -Wformat=2 -Wwrite-strings -Waggregate-return -Wmissing-declarations -Wredundant-decls -Winline -Wnested-externs -Wbad-function-cast -Werror"
+ CFLAGS="$CFLAGS -W -Wfloat-equal -Wundef -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wwrite-strings -Wredundant-decls -Wchar-subscripts -Wcomment -Wformat=2 -Wwrite-strings -Waggregate-return -Wmissing-declarations -Wredundant-decls -Wnested-externs -Wbad-function-cast -Wswitch-enum -Werror"
if test x$have_gcc4 = xyes ; then
# These warnings break gcc 3.3.5 and work on gcc 4.0.2
CFLAGS="$CFLAGS -Winit-self -Wmissing-field-initializers -Wdeclaration-after-statement -Wold-style-definition"
fi
+
+##This will break the world on some 64-bit architectures
+# CFLAGS="$CFLAGS -Winline"
+
fi
AC_OUTPUT(Makefile tor.spec contrib/tor.sh contrib/torctl contrib/torify contrib/tor.logrotate contrib/Makefile contrib/osx/Makefile contrib/osx/TorBundleDesc.plist contrib/osx/TorBundleInfo.plist contrib/osx/TorDesc.plist contrib/osx/TorInfo.plist contrib/osx/TorStartupDesc.plist src/config/torrc.sample doc/tor.1 src/Makefile doc/Makefile doc/design-paper/Makefile src/config/Makefile src/common/Makefile src/or/Makefile src/win32/Makefile src/tools/Makefile contrib/suse/Makefile contrib/suse/tor.sh)