aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorFelipe Bergo <bergo@seul.org>2002-06-29 20:01:58 +0000
committerFelipe Bergo <bergo@seul.org>2002-06-29 20:01:58 +0000
commite6f67fb15daa67b9f21052f5fb86ccd6641311b2 (patch)
tree0ea7df958347970be49828fceedee89d2eba46db /configure.in
parentdcc9fa865753626e365563f52d2104702c304eb2 (diff)
downloadtor-e6f67fb15daa67b9f21052f5fb86ccd6641311b2.tar
tor-e6f67fb15daa67b9f21052f5fb86ccd6641311b2.tar.gz
added some header checks
svn:r16
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index fa35db479..6422e2cd9 100644
--- a/configure.in
+++ b/configure.in
@@ -139,5 +139,7 @@ if (test ! -z "$ac_cv_openssldir" && test "x$ac_cv_openssldir" != "x(system)") ;
fi
LIBS="$saved_LIBS -lcrypto"
+AC_CHECK_HEADERS(unistd.h string.h signal.h netdb.h ctype.h sys/poll.h sys/types.h sys/fcntl.h sys/ioctl.h sys/socket.h sys/mman.h sys/stat.h sys/time.h netinet/in.h arpa/inet.h errno.h assert.h, , AC_MSG_WARN(some headers were not found, compilation may fail))
+
AC_OUTPUT(Makefile src/Makefile src/common/Makefile src/smtpap/Makefile src/orkeygen/Makefile src/httpap/Makefile src/op/Makefile src/or/Makefile)