aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-05-29 02:29:35 +0000
committerNick Mathewson <nickm@torproject.org>2008-05-29 02:29:35 +0000
commitac330d9ba72c2379372682216b329f384dbe30fe (patch)
tree35a3f7992afe4d4007d3aca45b2819bb70de2dbc /configure.in
parent6e68c23de74e613fb06cb4412c854845e46bed43 (diff)
downloadtor-ac330d9ba72c2379372682216b329f384dbe30fe.tar
tor-ac330d9ba72c2379372682216b329f384dbe30fe.tar.gz
New code to implement proposal for local geoip stats. Only enabled with --enable-geoip-stats passed to configure.
svn:r14802
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 0ae7cb965..975255340 100644
--- a/configure.in
+++ b/configure.in
@@ -87,6 +87,13 @@ case $host in
;;
esac
+AC_ARG_ENABLE(geoip-stats,
+ AS_HELP_STRING(--enable-geoip-stats, enable code for directories to collect per-country statistics))
+
+if test "$enable_geoip_stats" = "yes"; then
+ AC_DEFINE(ENABLE_GEOIP_STATS, 1, [Defined if we try to collect per-country statistics])
+fi
+
AC_ARG_ENABLE(gcc-warnings,
AS_HELP_STRING(--enable-gcc-warnings, enable verbose warnings))