aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-02-17 19:03:49 +0000
committerNick Mathewson <nickm@torproject.org>2008-02-17 19:03:49 +0000
commita8b371c333a03976111874a343c748c0fdbc8140 (patch)
tree6f796c3bcf11ee4c4585bf24f45c4dfd1ad64f14 /configure.in
parentfaa56a500b4bcdac6306c0c8b923bb1fb22267ec (diff)
downloadtor-a8b371c333a03976111874a343c748c0fdbc8140.tar
tor-a8b371c333a03976111874a343c748c0fdbc8140.tar.gz
r14238@tombo: nickm | 2008-02-17 14:03:44 -0500
Add openbsd memory allocator discussed in bug 468, to make it easier for linux users to get non-awful allocation patterns. Use --enable-openbsd-malloc to turn it on. Needs more testing. svn:r13544
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 93ce362d3..ec5cae78a 100644
--- a/configure.in
+++ b/configure.in
@@ -40,6 +40,9 @@ AC_ARG_ENABLE(cell-pool,
AS_HELP_STRING(--disable-cell-pool, disable pool allocator for cells))
AC_ARG_ENABLE(buf-freelists,
AS_HELP_STRING(--disable-buf-freelists, disable freelists for buffer RAM))
+AC_ARG_ENABLE(openbsd-malloc,
+ AS_HELP_STRING(--enable-openbsd-malloc, Use malloc code from openbsd. Linux only))
+
if test x$enable_cell_pool != xno; then
AC_DEFINE(ENABLE_CELL_POOL, 1,
@@ -49,6 +52,7 @@ if test x$enable_buf_freelists != xno; then
AC_DEFINE(ENABLE_BUF_FREELISTS, 1,
[Defined if we try to use freelists for buffer RAM chunks])
fi
+AM_CONDITIONAL(USE_OPENBSD_MALLOC, test x$enable_openbsd_malloc = xyes)
AC_ARG_ENABLE(transparent,
AS_HELP_STRING(--disable-transparent, disable transparent proxy support),