aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2005-02-22 04:26:45 +0000
committerNick Mathewson <nickm@torproject.org>2005-02-22 04:26:45 +0000
commita68fcbf807106417fb2410ce6a2592befaebe328 (patch)
treec1668e7df52e925ccdff7b252867a7bbfa587a17 /configure.in
parentc2d5b67dd2ba6b142db5b9c9aadaadd365b1404e (diff)
downloadtor-a68fcbf807106417fb2410ce6a2592befaebe328.tar
tor-a68fcbf807106417fb2410ce6a2592befaebe328.tar.gz
Initial IRIX compatibility fixes: check for inttypes.h; check for platform cell_t.
svn:r3648
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 0ecab905e..d411c9070 100644
--- a/configure.in
+++ b/configure.in
@@ -149,13 +149,14 @@ AC_CHECK_HEADERS(zlib.h, , AC_MSG_ERROR(Zlib header (zlib.h) not found. Tor requ
dnl These headers are not essential
-AC_CHECK_HEADERS(stdint.h sys/types.h inttypes.h sys/param.h sys/wait.h sys/limits.h netinet/in.h arpa/inet.h machine/limits.h syslog.h sys/time.h sys/resource.h pthread.h stddef.h)
+AC_CHECK_HEADERS(stdint.h sys/types.h inttypes.h sys/param.h sys/wait.h sys/limits.h netinet/in.h arpa/inet.h machine/limits.h syslog.h sys/time.h sys/resource.h pthread.h stddef.h inttypes.h)
AC_CHECK_FUNCS(gettimeofday ftime socketpair uname inet_aton strptime getrlimit setrlimit strlcat strlcpy strtoull getpwnam ftello pthread_create gethostbyname_r getaddrinfo)
AC_FUNC_FSEEKO
AC_CHECK_MEMBERS([struct timeval.tv_sec])
+
dnl In case we aren't given a working stdint.h, we'll need to grow our own.
dnl Watch out.
@@ -180,6 +181,10 @@ AC_CHECK_SIZEOF(long long)
AC_CHECK_SIZEOF(__int64)
AC_CHECK_SIZEOF(void *)
+# We want to make sure that we _don't_ have a cell_t defined, like IRIX does.
+
+AC_CHECK_SIZEOF(cell_t)
+
# Now, let's see about alignment requirements. On some platforms, we override
# the default.
case $host in