aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJacob Appelbaum <jacob@appelbaum.net>2011-06-19 02:31:13 -0700
committerRoger Dingledine <arma@torproject.org>2011-06-20 20:01:46 -0400
commit8b0d9452ca2053bbfba60750d169aaf52037cfcd (patch)
treed191e6101621f5b114db1e724d87dbb5f6352a1c /configure.in
parent8653f31d8d534282795acb54ee500ef7d42d3a32 (diff)
downloadtor-8b0d9452ca2053bbfba60750d169aaf52037cfcd.tar
tor-8b0d9452ca2053bbfba60750d169aaf52037cfcd.tar.gz
Fix tor-fw-helper-natpmp.c API usage
libnatpmp-20110618 changed the API that tor-fw-helper used and for a time tor-fw-helper could not build against the newest libnatpmp. This patch brings support for libnatpmp to tor-fw-helper.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index e5db37060..12922ae2e 100644
--- a/configure.in
+++ b/configure.in
@@ -545,7 +545,7 @@ if test "$natpmp" = "true"; then
[ int r;
natpmp_t natpmp;
natpmpresp_t response;
- r = initnatpmp(&natpmp);],
+ r = initnatpmp(&natpmp, 0, 0);],
[printf("initnatpmp() returned %d (%s)\n", r, r?"FAILED":"SUCCESS");
exit(0);],
[--with-libnatpmp-dir],