aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2003-08-11 20:50:30 +0000
committerNick Mathewson <nickm@torproject.org>2003-08-11 20:50:30 +0000
commit7284c25b3460790c3c0b61366c1b4350fc953746 (patch)
tree7d6c9abc112225fdcf16fb05a140ee4c41484ca3 /configure.in
parent52675184552c7284d4b4eb9a55f098cc80319f85 (diff)
downloadtor-7284c25b3460790c3c0b61366c1b4350fc953746.tar
tor-7284c25b3460790c3c0b61366c1b4350fc953746.tar.gz
Cope better on platforms that define some of intFOO_t in sys/types.h or elsewhere
svn:r377
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f977d4e9a..4338f2bd2 100644
--- a/configure.in
+++ b/configure.in
@@ -133,11 +133,17 @@ LIBS="$saved_LIBS -lcrypto"
dnl The warning message here is no longer strictly accurate.
-AC_CHECK_HEADERS(unistd.h string.h signal.h netdb.h ctype.h poll.h sys/poll.h sys/types.h sys/fcntl.h sys/ioctl.h sys/socket.h sys/time.h netinet/in.h arpa/inet.h errno.h assert.h stdint.h, , AC_MSG_WARN(some headers were not found, compilation may fail))
+AC_CHECK_HEADERS(unistd.h string.h signal.h netdb.h ctype.h poll.h sys/poll.h sys/types.h sys/fcntl.h sys/ioctl.h sys/socket.h sys/time.h netinet/in.h arpa/inet.h errno.h assert.h , , AC_MSG_WARN(some headers were not found, compilation may fail))
+
+dnl These headers are not essential
+
+AC_CHECK_HEADERS(stdint.h sys/types.h)
dnl In case we aren't given a working stdint.h, we'll need to grow our own.
dnl Watch out.
+AC_CHECK_TYPES([int8_t, int16_t, int32_t, int64_t])
+
AC_CHECK_SIZEOF(char)
AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)