aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@freehaven.net>2009-01-03 21:43:05 -0500
committerNick Mathewson <nickm@torproject.org>2009-04-29 14:46:04 -0400
commit6ac3a8b0cd1946e90a4c997e8fad1bfc63890abd (patch)
treee18fffa9c4b0ca4682ca36e607a6b6566946513b /configure.in
parente3ec061bc0ba9aa1bad1615f78fa7fe602e194e0 (diff)
downloadtor-6ac3a8b0cd1946e90a4c997e8fad1bfc63890abd.tar
tor-6ac3a8b0cd1946e90a4c997e8fad1bfc63890abd.tar.gz
Command-line option to dump SHA1 digests of all source files.
Now, when you call tor --digests, it dumps the SHA1 digest of each source file that Tor was built with. We support both 'sha1sum' and 'openssl sha1'. If the user is building from a tarball and they haven't edited anything, they don't need any program that calculates SHA1. If they _have_ modified a file but they don't have a program to calculate SHA1, we try to build so we do not output digests.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index a7ea5e1bb..2b8a91535 100644
--- a/configure.in
+++ b/configure.in
@@ -107,6 +107,10 @@ AC_PROG_CC
AC_PROG_CPP
AC_PROG_MAKE_SET
AC_PROG_RANLIB
+AC_PROG_SED
+
+AC_PATH_PROG([SHA1SUM], [sha1sum], none)
+AC_PATH_PROG([OPENSSL], [openssl], none)
TORUSER=_tor
AC_ARG_WITH(tor-user,