aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2010-10-20 13:01:30 +0200
committerSebastian Hahn <sebastian@torproject.org>2010-10-20 13:13:50 +0200
commit4f0badf974e05360d57926ddbd73677e5d3a5557 (patch)
treeeef1f4aa274b1f2ced59f8e9e45f93c9eef2b239 /configure.in
parent12d675a8dd9e1288c60db2107be269022c2ae4d4 (diff)
downloadtor-4f0badf974e05360d57926ddbd73677e5d3a5557.tar
tor-4f0badf974e05360d57926ddbd73677e5d3a5557.tar.gz
Remove redundant -Wpointer-sign CFLAG
-Wpointer-sign is implied with -Wall, which we use when building with --enable-gcc-warnings.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index ef358a808..65e82de7c 100644
--- a/configure.in
+++ b/configure.in
@@ -99,7 +99,7 @@ AC_ARG_ENABLE(gcc-hardening,
[if test x$enableval = xyes; then
CFLAGS="$CFLAGS -D_FORTIFY_SOURCE=2 -fstack-protector-all"
CFLAGS="$CFLAGS -fwrapv -fPIE -Wstack-protector"
- CFLAGS="$CFLAGS -Wpointer-sign --param ssp-buffer-size=1"
+ CFLAGS="$CFLAGS --param ssp-buffer-size=1"
LDFLAGS="$LDFLAGS -pie"
fi])