aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2008-05-16 20:13:10 +0000
committerNick Mathewson <nickm@torproject.org>2008-05-16 20:13:10 +0000
commit29a962475443d8ef979346e9b7452f159b3cde31 (patch)
treed20f2a2359cb2c0ec2961d6f7a28b4a42879191b /configure.in
parent3f55caa72260a2e2ce9ebd89416d7fb0617dbe4a (diff)
downloadtor-29a962475443d8ef979346e9b7452f159b3cde31.tar
tor-29a962475443d8ef979346e9b7452f159b3cde31.tar.gz
More muddling around to get configure.in to recognize recent libevents. Really, libevent should be fixed too so that the next poor sucker doesn't have to do this.
svn:r14641
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1ce1f7fa4..0ae7cb965 100644
--- a/configure.in
+++ b/configure.in
@@ -238,10 +238,14 @@ TOR_SEARCH_LIBRARY(libevent, $trylibeventdir, [-levent $TOR_LIB_WS32], [
#include <stdlib.h>
#include <sys/time.h>
#include <sys/types.h>
-#include <event.h>], [void exit(int); void *event_init(void);],
+#include <event.h>], [
+#ifdef WIN32
+#include <winsock2.h>
+#endif
+void exit(int); void *event_init(void);],
[
#ifdef WIN32
-{WSAData d; WSAStartup(0x101,&d); }
+{WSADATA d; WSAStartup(0x101,&d); }
#endif
event_init(); exit(0);
], [--with-libevent-dir], [/opt/libevent])