aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCristian Toader <cristian.matei.toader@gmail.com>2013-06-17 13:07:14 +0300
committerNick Mathewson <nickm@torproject.org>2013-07-11 09:13:13 -0400
commitf9c1ba6493478d227c202e4d3444283b2c840a6a (patch)
treec79191a86be32416dd1de5ead221b15e776e6114 /configure.ac
parentbcdc0022693c75ea1523468e783bf03832e0a358 (diff)
downloadtor-f9c1ba6493478d227c202e4d3444283b2c840a6a.tar
tor-f9c1ba6493478d227c202e4d3444283b2c840a6a.tar.gz
Add a basic seccomp2 syscall filter on Linux
It's controlled by the new Sandbox argument. Right now, it's rather coarse-grained, it's Linux-only, and it may break some features.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1e69ec48d..262b349b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -656,6 +656,12 @@ if test "$upnp" = "true"; then
fi
dnl ============================================================
+dnl Check for libseccomp
+
+AC_CHECK_HEADERS([seccomp.h])
+AC_SEARCH_LIBS(seccomp_init, [seccomp])
+
+dnl ============================================================
dnl We need an implementation of curve25519.
dnl set these defaults.