aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArlo Breault <arlolra@gmail.com>2013-05-14 10:18:28 -0700
committerNick Mathewson <nickm@torproject.org>2013-05-24 14:38:58 -0400
commitf5cf614ed3bfdf14b16242d4f1bec086224acf4e (patch)
treec541002254a973cac6af6130899276ff771c43b5 /configure.ac
parent5269f2b22e6c93a8a5171c2575b53d6aa88c3ccb (diff)
downloadtor-f5cf614ed3bfdf14b16242d4f1bec086224acf4e.tar
tor-f5cf614ed3bfdf14b16242d4f1bec086224acf4e.tar.gz
Config check for asciidoc and generated manpages.
If USE_ASCIIDOC is enabled but asciidoc isn't present and manpages aren't already generated, it'll throw a warning during configure. Works with the current git / tarball split. Caveat: regular_mans are listed in the configure.ac See #6506
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 03155dc89..2a53dd85a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1468,6 +1468,22 @@ AC_CONFIG_FILES([
src/config/torrc.sample
])
+if test x$asciidoc = xtrue && test $ASCIIDOC = "none" ; then
+ regular_mans=(doc/tor doc/tor-gencert doc/tor-resolve doc/torify)
+ for file in $regular_mans ; do
+ if ! [[ -f $file.1.in ]] || ! [[ -f $file.html.in ]] ; then
+ echo "==================================";
+ echo;
+ echo "You need asciidoc installed to be able to build the manpage.";
+ echo "To build without manpages, use the --disable-asciidoc argument";
+ echo "when calling configure.";
+ echo;
+ echo "==================================";
+ exit 1;
+ fi
+ done
+fi
+
AC_OUTPUT
if test -x /usr/bin/perl && test -x ./contrib/updateVersions.pl ; then