aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2014-04-30 12:48:46 -0400
committerNick Mathewson <nickm@torproject.org>2014-06-14 11:40:27 -0400
commite2e588175eac4ebe8fb47c0540954d0f78525cce (patch)
tree4326a57028c03348a7ddb7518eae7e244de9461a /configure.ac
parent34f8723dc784142b30d92bbbdeb37089ae7a3bc5 (diff)
downloadtor-e2e588175eac4ebe8fb47c0540954d0f78525cce.tar
tor-e2e588175eac4ebe8fb47c0540954d0f78525cce.tar.gz
New testing-only tor_sleep_msec function
In the unit tests I want to loop with a delay, but I want less than a 1 second delay. This, sadly, requires compatibility code.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c0c818757..c662a9fc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -355,6 +355,7 @@ AC_CHECK_FUNCS(
sysconf \
sysctl \
uname \
+ usleep \
vasprintf \
_vscprintf
)
@@ -885,6 +886,7 @@ AC_CHECK_HEADERS(
sys/param.h \
sys/prctl.h \
sys/resource.h \
+ sys/select.h \
sys/socket.h \
sys/sysctl.h \
sys/syslimits.h \