aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-10-30 22:39:53 -0400
committerNick Mathewson <nickm@torproject.org>2013-10-30 22:39:53 -0400
commit9b0a4cbe9256f3b9dda7a5b6d0611a8449994548 (patch)
treea54efba17163c12257ad1d323cee676878c49992 /configure.ac
parent9e0ed8136a53665a21ecdf2bc335cc8ce438e0c8 (diff)
downloadtor-9b0a4cbe9256f3b9dda7a5b6d0611a8449994548.tar
tor-9b0a4cbe9256f3b9dda7a5b6d0611a8449994548.tar.gz
Add the -Wlogical-op switch when building with GCC 4.3 or later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8d21661f8..974ff2707 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1494,7 +1494,7 @@ if test x$enable_gcc_warnings = xyes || test x$enable_gcc_warnings_advisory = xy
if test x$have_gcc43 = xyes ; then
# These warnings break gcc 4.2 and work on gcc 4.3
# XXXX020 See if any of these work with earlier versions.
- CFLAGS="$CFLAGS -Wextra -Warray-bounds"
+ CFLAGS="$CFLAGS -Wextra -Warray-bounds -Wlogical-op"
fi
if test x$have_shorten64_flag = xyes ; then