aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-01-30 13:08:04 -0500
committerNick Mathewson <nickm@torproject.org>2013-01-30 13:08:04 -0500
commit97d0872f59b4ac7a56632966ee041782c1152313 (patch)
tree5a3a1e5c4cc154c7896f47fa089f53648efef72c /configure.ac
parent73f85905aa9cfe6ee4f014f54d5713ab662c207a (diff)
downloadtor-97d0872f59b4ac7a56632966ee041782c1152313.tar
tor-97d0872f59b4ac7a56632966ee041782c1152313.tar.gz
Build donna32 with -fomit-frame-pointer
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f047ab902..5468b9626 100644
--- a/configure.ac
+++ b/configure.ac
@@ -583,6 +583,19 @@ if test x$enable_linker_hardening != xno; then
fi
dnl ------------------------------------------------------
+dnl Now see if we have a -fomit-frame-pointer compiler option.
+
+saved_CFLAGS="$CFLAGS"
+TOR_CHECK_CFLAGS(-fomit-frame-pointer)
+if test "$saved_CFLAGS" != "$CFLAGS"; then
+ F_OMIT_FRAME_POINTER='-fomit-frame-pointer'
+else
+ F_OMIT_FRAME_POINTER=''
+fi
+CFLAGS="$saved_CFLAGS"
+AC_SUBST(F_OMIT_FRAME_POINTER)
+
+dnl ------------------------------------------------------
dnl Where do you live, libnatpmp? And how do we call you?
dnl There are no packages for Debian or Redhat as of this patch