aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2014-05-05 11:44:02 -0400
committerNick Mathewson <nickm@torproject.org>2014-05-05 11:44:02 -0400
commit388478561dd4457afedf530591f02cb05864b187 (patch)
treefb71c8f7a93d923c84db702b8fc635e8420a1128 /configure.ac
parent5d496963b4a98512711bd4cbc5565535d89e7845 (diff)
downloadtor-388478561dd4457afedf530591f02cb05864b187.tar
tor-388478561dd4457afedf530591f02cb05864b187.tar.gz
Fix cross-compiling when 128-bit math compiles but won't link
Apparently, there exist cross-compiling environments for arm7 where you can compile a 64x64->128 multiply, but not link it. Fixes bug 11729; bugfix on 0.2.4.8-alpha. Patch from 'conradev'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 3ef5cdd7d..a96a333c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -770,7 +770,7 @@ if test x$enable_curve25519 != xno; then
])],
[tor_cv_can_use_curve25519_donna_c64=yes],
[tor_cv_can_use_curve25519_donna_c64=no],
- [AC_COMPILE_IFELSE(
+ [AC_LINK_IFELSE(
[AC_LANG_PROGRAM([dnl
#include <stdint.h>
typedef unsigned uint128_t __attribute__((mode(TI)));