aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-03-11 15:33:44 -0400
committerNick Mathewson <nickm@torproject.org>2013-03-11 15:33:44 -0400
commit2f98bf5c9fac4dfd1bb07564ce08b13d1e330252 (patch)
treecbd37edff429666bbb4b05ff9780c4ec7d66f2ea /configure.ac
parentef4db3169344567f30fb72e3e9a66154b976d889 (diff)
downloadtor-2f98bf5c9fac4dfd1bb07564ce08b13d1e330252.tar
tor-2f98bf5c9fac4dfd1bb07564ce08b13d1e330252.tar.gz
Warn at configure time when time_t is unsigned
Inspired by #8042. As far as I know, OpenVMS is the only place you're likely to hit an unsigned time_t these days, and Tor's VMS support is... lacking. Still worth letting people know about it, though.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 864477b8f..21a83bc4c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -972,6 +972,10 @@ AX_CHECK_SIGN([time_t],
#endif
])
+if test "$ax_cv_decl_time_t_signed" = no; then
+ AC_MSG_WARN([You have an unsigned time_t; some things will probably break. Please tell the Tor developers about your interesting platform.])
+fi
+
AX_CHECK_SIGN([size_t],
[ tor_cv_size_t_signed=yes ],
[ tor_cv_size_t_signed=no ], [