aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-07-26 12:46:17 +0200
committerNick Mathewson <nickm@torproject.org>2013-11-18 10:43:15 -0500
commit2662885aa9cb6c9b7447b729d0321a633e8c46c3 (patch)
tree6a55e91c2b1bf172a56418e6304823dafd1cc0f3 /configure.ac
parentce8ae49c9437086a886af631d3f618ec338637d0 (diff)
downloadtor-2662885aa9cb6c9b7447b729d0321a633e8c46c3.tar
tor-2662885aa9cb6c9b7447b729d0321a633e8c46c3.tar.gz
Use pc_from_ucontext.m4 from Google Performance Tools
This M4 module lets us learn the right way (out of at least 18 possibilities) to extract the current PC for stack-trace-fixup-in-signal purposes. The Google Performance Tools license is 3-clause BSD.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8e247db32..06e9e3b37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -937,6 +937,8 @@ AC_CHECK_SIZEOF(pid_t)
AC_CHECK_TYPES([uint, u_char, ssize_t])
+AC_PC_FROM_UCONTEXT([/bin/true])
+
dnl used to include sockaddr_storage, but everybody has that.
AC_CHECK_TYPES([struct in6_addr, struct sockaddr_in6, sa_family_t], , ,
[#ifdef HAVE_SYS_TYPES_H