aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-10-11 13:05:58 -0400
committerNick Mathewson <nickm@torproject.org>2013-10-11 13:07:14 -0400
commit187398318ef9b8b66e0f19ef031a847e8824e1d1 (patch)
tree305cbca569bc9825240cd92e7f023315daa9db95 /configure.ac
parent0546edde66b3ca3dfbbd51f95b906d9e8f4f1459 (diff)
downloadtor-187398318ef9b8b66e0f19ef031a847e8824e1d1.tar
tor-187398318ef9b8b66e0f19ef031a847e8824e1d1.tar.gz
When python is available, run the commandline unit tests from "make check"
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 926b53d49..77767c52a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -183,6 +183,13 @@ AM_CONDITIONAL(NAT_PMP, test x$natpmp = xtrue)
AM_CONDITIONAL(MINIUPNPC, test x$upnp = xtrue)
AM_PROG_CC_C_O
+AC_ARG_VAR(PYTHON)
+AC_CHECK_PROGS(PYTHON, [python python2 python3])
+if test "x$PYTHON" = "x"; then
+ AC_MSG_WARN([Python unavailable; some tests will not be run.])
+fi
+AM_CONDITIONAL(USEPYTHON, [test "x$PYTHON" != "x"])
+
ifdef([AC_C_FLEXIBLE_ARRAY_MEMBER], [
AC_C_FLEXIBLE_ARRAY_MEMBER
], [