aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-03-15 10:48:33 -0400
committerNick Mathewson <nickm@torproject.org>2013-03-15 11:00:43 -0400
commit10fb3398087133add9aff93740aff8f818edf242 (patch)
treec147eafeeb752a0221487132a6d0a8293a523744 /configure.ac
parent653b09e1ec27bc2c8676c3c1ec40264972540637 (diff)
downloadtor-10fb3398087133add9aff93740aff8f818edf242.tar
tor-10fb3398087133add9aff93740aff8f818edf242.tar.gz
Be explicit that we want not only nacl but nacl-with-a-fast-curve25519
Resolves the user experience part of #8014.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4bc0db363..d58898416 100644
--- a/configure.ac
+++ b/configure.ac
@@ -693,7 +693,7 @@ if test x$enable_curve25519 != xno; then
AC_CHECK_HEADERS([crypto_scalarmult_curve25519.h \
nacl/crypto_scalarmult_curve25519.h])
- AC_CACHE_CHECK([whether we can use curve25519 from nacl],
+ AC_CACHE_CHECK([for nacl compiled with a fast curve25519 implementation],
tor_cv_can_use_curve25519_nacl,
[tor_saved_LIBS="$LIBS"
LIBS="$LIBS -lnacl"
@@ -705,7 +705,7 @@ if test x$enable_curve25519 != xno; then
#include <nacl/crypto_scalarmult_curve25519.h>
#endif
#ifdef crypto_scalarmult_curve25519_ref_BYTES
- #error Hey, this is the reference implementation!
+ #error Hey, this is the reference implementation! That's not fast.
#endif
], [
unsigned char *a, *b, *c; crypto_scalarmult_curve25519(a,b,c);