aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-09-09 15:18:54 -0400
committerNick Mathewson <nickm@torproject.org>2013-09-09 15:18:54 -0400
commit05f8429a280f80c94fa7c01f6a5c4b654cd02286 (patch)
treeb8e4e425f5ca96b979be159eff0b1300925848eb /configure.ac
parenta6ada1a50cbedebf15667b4448f6890140f56001 (diff)
downloadtor-05f8429a280f80c94fa7c01f6a5c4b654cd02286.tar
tor-05f8429a280f80c94fa7c01f6a5c4b654cd02286.tar.gz
Split libevent AC_CHECK_FUNCS call into multiple lines
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 68c8ce47b..e2b2dd60c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -395,7 +395,12 @@ save_CPPFLAGS="$CPPFLAGS"
LIBS="-levent $STATIC_LIBEVENT_FLAGS $TOR_LIB_WS32 $LIBS"
LDFLAGS="$TOR_LDFLAGS_libevent $LDFLAGS"
CPPFLAGS="$TOR_CPPFLAGS_libevent $CPPFLAGS"
-AC_CHECK_FUNCS(event_get_version event_get_version_number event_get_method event_set_log_callback evdns_set_outgoing_bind_address event_base_loopexit)
+AC_CHECK_FUNCS([event_get_version \
+ event_get_version_number \
+ event_get_method \
+ event_set_log_callback \
+ evdns_set_outgoing_bind_address \
+ event_base_loopexit])
AC_CHECK_MEMBERS([struct event.min_heap_idx], , ,
[#include <event.h>
])