aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2009-09-21 14:23:13 -0400
committerNick Mathewson <nickm@torproject.org>2009-09-23 00:24:43 -0400
commitd4b54549b83bbbfeb9c1d7d843ea244eed389c61 (patch)
tree07456ee45551880371239a77621bd7e35ed2ab0a /Makefile.am
parent1c2d7732f0a2d74e61bc4276421bec78b2256f64 (diff)
downloadtor-d4b54549b83bbbfeb9c1d7d843ea244eed389c61.tar
tor-d4b54549b83bbbfeb9c1d7d843ea244eed389c61.tar.gz
Refactor unit tests to use the tinytest framework.
"Tinytest" is a minimalist C unit testing framework I wrote for Libevent. It supports some generally useful features, like being able to run separate unit tests in their own processes. I tried to do the refactoring to change test.c as little as possible. Thus, we mostly don't call the tinytest macros directly. Instead, the test.h header is now a wrapper on tinytest.h to make our existing test_foo() macros work. The next step(s) here will be: - To break test.c into separate files, each with its own test group. - To look into which things we can test - To refactor the more fiddly tests to use the tinytest macros directly and/or run forked. - To see about writing unit tests for things we couldn't previously test without forking.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index aa679e556..4e049a03a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,7 +66,7 @@ check-spaces:
./contrib/checkSpace.pl -C \
src/common/*.h \
src/common/[^asO]*.c src/common/address.c \
- src/or/[^et]*.[ch] src/or/t*.c src/or/eventdns_tor.h
+ src/or/[^et]*.[ch] src/or/t[^i]*.c src/or/eventdns_tor.h
check-docs:
./contrib/checkOptionDocs.pl