aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2004-03-02 19:09:30 +0000
committerNick Mathewson <nickm@torproject.org>2004-03-02 19:09:30 +0000
commita1503f667ef8b4eeaab81b0c50f273026ca4474a (patch)
treeac31a100c0afd73f2b2e4c29ba86671f2faf9ae0 /Makefile.am
parent4f6cf727b9af6070ed6db02f8be5e17057a04a60 (diff)
downloadtor-a1503f667ef8b4eeaab81b0c50f273026ca4474a.tar
tor-a1503f667ef8b4eeaab81b0c50f273026ca4474a.tar.gz
Integrate jbash's RPM spec into build process. (Requires "rpmbuild" to
build properly. Works fine on redhat 9. YMMV.) svn:r1199
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 155b2557e..8502682ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -9,3 +9,13 @@ EXTRA_DIST = INSTALL README AUTHORS LICENSE ChangeLog
#install-data-local:
# $(INSTALL) -m 755 -d $(LOCALSTATEDIR)/lib/tor
+
+dist-rpm: dist
+ rm -rf /tmp/tor-rpm-build
+ mkdir /tmp/tor-rpm-build
+ for subdir in BUILD RPMS SOURCES SPECS SRPMS; do \
+ mkdir /tmp/tor-rpm-build/$$subdir; \
+ done
+ cp tor-$(VERSION).tar.gz /tmp/tor-rpm-build/SOURCES
+ rpmbuild -ba --define '_topdir /tmp/tor-rpm-build' contrib/tor.spec
+ mv /tmp/tor-rpm-build/*RPMS/* .