aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndrew Lewman <andrew@torproject.org>2006-04-13 01:46:27 +0000
committerAndrew Lewman <andrew@torproject.org>2006-04-13 01:46:27 +0000
commit73c268707bc32b91e3cb72d5b420e6470278ea7a (patch)
tree6827348e4a1dcb48c7720b4d5ea79ccaf20ee676 /Makefile.am
parent64041d2dbf6076205b1e140cc7194f0a7a001019 (diff)
downloadtor-73c268707bc32b91e3cb72d5b420e6470278ea7a.tar
tor-73c268707bc32b91e3cb72d5b420e6470278ea7a.tar.gz
Temporary hacks to ensure make dist-rpm works from cvs until a better
solution can be found. svn:r6383
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cd4dbc398..25215a912 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -23,7 +23,8 @@ dist-rpm:
for subdir in BUILD RPMS SOURCES SPECS SRPMS; do \
mkdir $$RPM_BUILD_DIR/$$subdir; \
done; \
- cp ../tor-$(VERSION).tar.gz $$RPM_BUILD_DIR/SOURCES; \
+ tar zcf tor-$(VERSION).tar.gz ../tor; \
+ cp tor-$(VERSION).tar.gz $$RPM_BUILD_DIR/SOURCES; \
rpmbuild -ba --define "_topdir $$RPM_BUILD_DIR" tor.spec; \
mv $$RPM_BUILD_DIR/SRPMS/* .; \
mv $$RPM_BUILD_DIR/RPMS/* .; \