aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStewart Smith <stewart@flamingspork.com>2012-08-02 23:31:43 +1000
committerNick Mathewson <nickm@torproject.org>2012-08-09 11:03:47 -0400
commit2a4a1496241d6c4183763f90600be4775ccb5470 (patch)
tree99ec92b85e229d4e8aee6b90a0f1aede1dad180a /Makefile.am
parentca90aea5ebde66565fbb6fb5d0e88a970d3563a5 (diff)
downloadtor-2a4a1496241d6c4183763f90600be4775ccb5470.tar
tor-2a4a1496241d6c4183763f90600be4775ccb5470.tar.gz
Move to non-recursive make
This gives us a few benefits: 1) make -j clean all this will start working, as it should. It currently doesn't. 2) increased parallel build recursive make will max out at number of files in a directory, non-recursive make doesn't have such a limitation 3) Removal of duplicate information in make files, less error prone I've also slightly updated how we call AM_INIT_AUTOMAKE, as the way that was used was not only deprecated but will be *removed* in the next major automake release (1.13).... so probably best that we can continue to bulid tor without requiring old automake. (see http://www.gnu.org/software/automake/manual/html_node/Public-Macros.html ) For more reasons why, see resources such as: http://miller.emu.id.au/pmiller/books/rmch/
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 29bba715b..819795c5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,11 +7,21 @@
# 1.7 means we require automake vesion 1.7
AUTOMAKE_OPTIONS = foreign 1.7
-SUBDIRS = src doc contrib
+noinst_LIBRARIES=
+EXTRA_DIST=
+noinst_HEADERS=
+bin_PROGRAMS=
+CLEANFILES=
+TESTS=
+noinst_PROGRAMS=
+DISTCLEANFILES=
+bin_SCRIPTS=
+include src/include.am
+include doc/include.am
+include contrib/include.am
-DIST_SUBDIRS = src doc contrib
-EXTRA_DIST = \
+EXTRA_DIST+= \
ChangeLog \
INSTALL \
LICENSE \