aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2010-11-11 14:22:48 -0500
committerNick Mathewson <nickm@torproject.org>2010-11-11 14:22:48 -0500
commit223fc208f61ab2d12eecfb6dc169927300cde941 (patch)
treea0d83f76e006a9041c6077a47e748100a9f332f9 /Makefile.am
parent2b4ed1d07e5b03f368ccc23e44c2189d5dedc3fd (diff)
downloadtor-223fc208f61ab2d12eecfb6dc169927300cde941.tar
tor-223fc208f61ab2d12eecfb6dc169927300cde941.tar.gz
Split long lines in configure.in and Makefile.am files
Having very long single lines with lots and lots of things in them tends to make files hard to diff and hard to merge. Since our tools are one-line-at-a-time, we should try to construct lists that way too, within reason. This incidentally turned up a few headers in configure.in that we were for some reason searching for twice.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am19
1 files changed, 14 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 5a7f31e20..e2c93d810 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,8 +11,14 @@ SUBDIRS = src doc contrib
DIST_SUBDIRS = src doc contrib
-EXTRA_DIST = INSTALL README LICENSE ChangeLog \
- ReleaseNotes tor.spec tor.spec.in
+EXTRA_DIST = \
+ ChangeLog \
+ INSTALL \
+ LICENSE \
+ README \
+ ReleaseNotes \
+ tor.spec \
+ tor.spec.in
#install-data-local:
# $(INSTALL) -m 755 -d $(LOCALSTATEDIR)/lib/tor
@@ -48,9 +54,12 @@ test: all
check-spaces:
./contrib/checkSpace.pl -C \
src/common/*.h \
- src/common/[^asO]*.c src/common/address.c \
- src/or/[^e]*.[ch] src/or/eventdns_tor.h \
- src/test/test*.[ch] src/tools/*.[ch] \
+ src/common/[^asO]*.c \
+ src/common/address.c \
+ src/or/[^e]*.[ch] \
+ src/or/eventdns_tor.h \
+ src/test/test*.[ch] \
+ src/tools/*.[ch] \
src/tools/tor-fw-helper/*.[ch]
check-docs: