aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristopher Baines <chris@dheneb.cbaines.net>2015-11-22 16:43:24 +0000
committerChristopher Baines <chris@dheneb.cbaines.net>2015-11-22 16:45:16 +0000
commit147d916d9cc641d496b8bbb32b7db99701038491 (patch)
treeadace5c67cf71210a14cdbcb2a979e4865272257 /setup.py
downloadsklearn-pandas-147d916d9cc641d496b8bbb32b7db99701038491.tar
sklearn-pandas-147d916d9cc641d496b8bbb32b7db99701038491.tar.gz
Imported Upstream version 0.0.12upstream/0.0.12
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py47
1 files changed, 47 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..143f2f6
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,47 @@
+#!/usr/bin/env python
+# -*- coding: utf-8 -*-
+
+from setuptools import setup
+from setuptools.command.test import test as TestCommand
+import re
+
+for line in open('sklearn_pandas/__init__.py'):
+ match = re.match("__version__ *= *'(.*)'", line)
+ if match:
+ __version__, = match.groups()
+
+
+class PyTest(TestCommand):
+ user_options = [('pytest-args=', 'a', "Arguments to pass to py.test")]
+
+ def initialize_options(self):
+ TestCommand.initialize_options(self)
+ self.pytest_args = []
+
+ def finalize_options(self):
+ TestCommand.finalize_options(self)
+ self.test_args = []
+ self.test_suite = True
+
+ def run(self):
+ import pytest
+ errno = pytest.main(self.pytest_args)
+ raise SystemExit(errno)
+
+
+setup(name='sklearn-pandas',
+ version=__version__,
+ description='Pandas integration with sklearn',
+ maintainer='Israel Saeta PĂ©rez',
+ maintainer_email='israel.saeta@dukebody.com',
+ url='https://github.com/paulgb/sklearn-pandas',
+ packages=['sklearn_pandas'],
+ keywords=['scikit', 'sklearn', 'pandas'],
+ install_requires=[
+ 'scikit-learn>=0.13',
+ 'scipy>=0.14',
+ 'pandas>=0.11.0',
+ 'numpy>=1.6.1'],
+ tests_require=['pytest', 'mock'],
+ cmdclass={'test': PyTest},
+ )