aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 4 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 6bdb7b9..0a2dac3 100644
--- a/setup.py
+++ b/setup.py
@@ -6,9 +6,9 @@ import os
import re
try:
- import setuptools
+ import setuptools # noqa: unused
except ImportError:
- pass # No 'develop' command, oh well.
+ pass # No 'develop' command, oh well.
base_path = os.path.dirname(__file__)
@@ -55,14 +55,11 @@ setup(name='urllib3',
],
test_suite='test',
extras_require={
- 'secure;python_version<="2.7"': [
- 'pyOpenSSL',
+ 'secure': [
+ 'pyOpenSSL>=0.13',
'ndg-httpsclient',
'pyasn1',
'certifi',
],
- 'secure;python_version>"2.7"': [
- 'certifi',
- ],
},
)