aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rw-r--r--debian/control4
-rw-r--r--debian/patches/01_do-not-use-embedded-python-six.patch10
3 files changed, 20 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 5d241dc..3fdef6e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+python-urllib3 (1.11-1) unstable; urgency=medium
+
+ * New upstream release.
+ * debian/control
+ - Add python{,3}-tornado to Build-Depends.
+ - Add python-ntlm to python-urllib3's Suggests.
+ * debian/patches/01_do-not-use-embedded-python-six.patch
+ - Refresh.
+
+ -- Daniele Tricoli <eriol@mornie.org> Mon, 17 Aug 2015 18:51:43 +0200
+
python-urllib3 (1.10.4-1) unstable; urgency=medium
* New upstream release.
diff --git a/debian/control b/debian/control
index 922a4f5..10db0b4 100644
--- a/debian/control
+++ b/debian/control
@@ -12,12 +12,14 @@ Build-Depends:
python-nose (>=1.3.3),
python-setuptools,
python-six,
+ python-tornado,
python3-all,
python3-coverage (>= 3.6),
python3-mock,
python3-nose (>=1.3.3),
python3-setuptools,
python3-six,
+ python3-tornado,
python3-wheel,
Standards-Version: 3.9.6
X-Python-Version: >= 2.6
@@ -37,6 +39,8 @@ Recommends:
python-ndg-httpsclient,
python-openssl,
python-pyasn1
+Suggests:
+ python-ntlm
Description: HTTP library with thread-safe connection pooling for Python
urllib3 supports features left out of urllib and urllib2 libraries.
.
diff --git a/debian/patches/01_do-not-use-embedded-python-six.patch b/debian/patches/01_do-not-use-embedded-python-six.patch
index 2ad8061..9f4c025 100644
--- a/debian/patches/01_do-not-use-embedded-python-six.patch
+++ b/debian/patches/01_do-not-use-embedded-python-six.patch
@@ -16,7 +16,7 @@ Last-Update: 2015-05-03
from nose.plugins.skip import SkipTest
--- a/urllib3/connectionpool.py
+++ b/urllib3/connectionpool.py
-@@ -27,7 +27,7 @@
+@@ -28,7 +28,7 @@
InsecureRequestWarning,
)
from .packages.ssl_match_hostname import CertificateError
@@ -40,14 +40,14 @@ Last-Update: 2015-05-03
writer = codecs.lookup('utf-8')[3]
--- a/urllib3/response.py
+++ b/urllib3/response.py
-@@ -10,7 +10,7 @@
+@@ -11,7 +11,7 @@
from .exceptions import (
ProtocolError, DecodeError, ReadTimeoutError, ResponseNotChunked
)
-from .packages.six import string_types as basestring, binary_type, PY3
+from six import string_types as basestring, binary_type, PY3
from .connection import HTTPException, BaseSSLError
- from .util.response import is_fp_closed
+ from .util.response import is_fp_closed, is_response_to_head
--- a/test/test_filepost.py
+++ b/test/test_filepost.py
@@ -62,7 +62,7 @@ Last-Update: 2015-05-03
BOUNDARY = '!! test boundary !!'
--- a/dummyserver/handlers.py
+++ b/dummyserver/handlers.py
-@@ -211,7 +211,7 @@
+@@ -261,7 +261,7 @@
"""
import tornado.httputil
import email.utils
@@ -149,7 +149,7 @@ Last-Update: 2015-05-03
ConnectTimeoutError,
--- a/test/__init__.py
+++ b/test/__init__.py
-@@ -7,7 +7,7 @@
+@@ -8,7 +8,7 @@
from nose.plugins.skip import SkipTest
from urllib3.exceptions import MaxRetryError, HTTPWarning