aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog13
-rw-r--r--debian/control2
-rw-r--r--debian/patches/01_do-not-use-embedded-python-six.patch48
-rwxr-xr-xdebian/rules7
4 files changed, 41 insertions, 29 deletions
diff --git a/debian/changelog b/debian/changelog
index 2ac55dd..8d90785 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+python-urllib3 (1.5-1) experimental; urgency=low
+
+ * New upstream release
+ * debian/control
+ - Bumped Standards-Version to 3.9.4 (no changes needed)
+ * debian/patches/01_do-not-use-embedded-python-six.patch
+ - Refreshed
+ * debian/rules
+ - Run tests only for python2.7 since upstream is using
+ assertRaises() as a context manager
+
+ -- Daniele Tricoli <eriol@mornie.org> Fri, 09 Nov 2012 04:23:18 +0100
+
python-urllib3 (1.3-3) unstable; urgency=low
* debian/control
diff --git a/debian/control b/debian/control
index 2e522c7..87cd849 100644
--- a/debian/control
+++ b/debian/control
@@ -12,7 +12,7 @@ Build-Depends:
python-six,
python-tornado,
python3-all
-Standards-Version: 3.9.3
+Standards-Version: 3.9.4
X-Python-Version: >= 2.6
X-Python3-Version: >= 3.0
Homepage: http://urllib3.readthedocs.org
diff --git a/debian/patches/01_do-not-use-embedded-python-six.patch b/debian/patches/01_do-not-use-embedded-python-six.patch
index 6729f1d..111513d 100644
--- a/debian/patches/01_do-not-use-embedded-python-six.patch
+++ b/debian/patches/01_do-not-use-embedded-python-six.patch
@@ -1,73 +1,73 @@
Description: Do not use embedded copy of python-six.
Author: Daniele Tricoli <eriol@mornie.org>
Forwarded: not-needed
-Last-Update: 2012-04-17
+Last-Update: 2012-11-09
--- a/test/test_collections.py
+++ b/test/test_collections.py
@@ -1,7 +1,7 @@
import unittest
-
+
from urllib3._collections import RecentlyUsedContainer as Container
-from urllib3.packages import six
+import six
xrange = six.moves.xrange
-
-
+
+
--- a/urllib3/connectionpool.py
+++ b/urllib3/connectionpool.py
-@@ -51,7 +51,7 @@
+@@ -52,7 +52,7 @@
)
-
+
from .packages.ssl_match_hostname import match_hostname, CertificateError
-from .packages import six
+import six
-
-
+
+
xrange = six.moves.xrange
--- a/urllib3/filepost.py
+++ b/urllib3/filepost.py
-@@ -14,8 +14,8 @@
-
+@@ -10,8 +10,8 @@
+ from uuid import uuid4
from io import BytesIO
-
+
-from .packages import six
-from .packages.six import b
+import six
+from six import b
-
+
writer = codecs.lookup('utf-8')[3]
-
+
--- a/urllib3/response.py
+++ b/urllib3/response.py
@@ -11,7 +11,7 @@
from io import BytesIO
-
- from .exceptions import HTTPError
+
+ from .exceptions import DecodeError
-from .packages.six import string_types as basestring
+from six import string_types as basestring
-
-
+
+
log = logging.getLogger(__name__)
--- a/urllib3/util.py
+++ b/urllib3/util.py
-@@ -16,7 +16,7 @@
+@@ -18,7 +18,7 @@
except ImportError: # `select` doesn't exist on AppEngine.
select = False
-
+
-from .packages import six
+import six
from .exceptions import LocationParseError
-
-
+
+
--- a/test/test_filepost.py
+++ b/test/test_filepost.py
@@ -1,7 +1,7 @@
import unittest
-
+
from urllib3.filepost import encode_multipart_formdata, iter_fields
-from urllib3.packages.six import b, u
+from six import b, u
-
-
+
+
BOUNDARY = '!! test boundary !!'
diff --git a/debian/rules b/debian/rules
index 6207fb9..e2ed423 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,10 +43,9 @@ override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
# Python3 testing is not possible at the moment because missing
# dependencies: python3-coverage.
- set -ex; \
- for python in $(PYVERS); do \
- $$python /usr/bin/nosetests; \
- done
+ # Upstream is using a python2.7 features: assertRaises() as a context
+ # manager
+ set -ex; python2.7 /usr/bin/nosetests
endif
override_dh_installchangelogs: