aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 42f5d36..f3dea6c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,6 @@
#!/usr/bin/make -f
-export PYBUILD_DESTDIR_python2=debian/python-urllib3/
-export PYBUILD_DESTDIR_python3=debian/python3-urllib3/
+export PYBUILD_NAME=urllib3
export PYTHONWARNINGS=d
@@ -15,6 +14,9 @@ override_dh_auto_install:
dh_auto_install
# Remove dummyserver/ tests to not pollute namespace.
rm -rf debian/python*-urllib3/usr/lib/python*/dist-packages/dummyserver
+ python3 setup.py bdist_wheel \
+ --universal \
+ -d $(CURDIR)/debian/tmp/usr/share/python-wheels
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))