aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorBarry Warsaw <barry@debian.org>2014-05-13 01:15:29 +0000
committerBarry Warsaw <barry@debian.org>2014-05-13 01:15:29 +0000
commit4278e068e0caa2c010b2b6c8765b1b6b2657c770 (patch)
tree6b704217e6c1857d07a1c51ac208a44e209dfa3b /debian/rules
parent5eef2dd62a1481f5874f6a8f7721cf22b1e6f293 (diff)
downloadpython-urllib3-4278e068e0caa2c010b2b6c8765b1b6b2657c770.tar
python-urllib3-4278e068e0caa2c010b2b6c8765b1b6b2657c770.tar.gz
* d/control:
- Added python-setuptools, python3-setuptools, and python3-wheel to Build-Depends. - Added python-urllib3-wheels binary package. * d/rules: - Build the universal wheels. - Simplify through use of PYBUILD_NAME. * d/python-urllib3-wheels.install: Added. * d/patches/setuptools.patch: Use setuptools.setup() so that the bdist_wheel command will work.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 4 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 42f5d36..f3dea6c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,6 @@
#!/usr/bin/make -f
-export PYBUILD_DESTDIR_python2=debian/python-urllib3/
-export PYBUILD_DESTDIR_python3=debian/python3-urllib3/
+export PYBUILD_NAME=urllib3
export PYTHONWARNINGS=d
@@ -15,6 +14,9 @@ override_dh_auto_install:
dh_auto_install
# Remove dummyserver/ tests to not pollute namespace.
rm -rf debian/python*-urllib3/usr/lib/python*/dist-packages/dummyserver
+ python3 setup.py bdist_wheel \
+ --universal \
+ -d $(CURDIR)/debian/tmp/usr/share/python-wheels
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))