aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index e66f170..e94c934 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,8 +16,9 @@ override_dh_auto_install:
-d $(CURDIR)/debian/tmp/usr/share/python-wheels
override_dh_auto_test:
+ # Exclude dummyserver tests since they are also failing upstream.
PYBUILD_SYSTEM=custom \
- PYBUILD_TEST_ARGS="cd {build_dir}; {interpreter} -m nose {dir}/test --with-coverage" dh_auto_test
+ PYBUILD_TEST_ARGS="cd {build_dir}; {interpreter} -m nose {dir}/test --with-coverage -e with_dummyserver" dh_auto_test
# Clean here .coverage because it is created by nose using the coverage
# plugin
find . -name .coverage -delete