aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2012-02-10 03:42:16 +0000
committerDaniele Tricoli <eriol@mornie.org>2012-02-10 03:42:16 +0000
commitde411c0d244fa87ae28cd1d96382e6a39c4fd2f0 (patch)
tree0a3a221d75097c686c10b7db15ff2fa6a022ffb2 /debian
parent59d31a36678c7a10993d30c3c060b0b556fa9deb (diff)
downloadpython-urllib3-de411c0d244fa87ae28cd1d96382e6a39c4fd2f0.tar
python-urllib3-de411c0d244fa87ae28cd1d96382e6a39c4fd2f0.tar.gz
Added override_dh_auto_clean to build the package twice in a row
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules5
2 files changed, 6 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index e3a56b9..76a02fa 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,4 +2,4 @@ python-urllib3 (1.2.2-1) UNRELEASED; urgency=low
* Initial release (Closes: #648783)
- -- Daniele Tricoli <eriol@mornie.org> Fri, 10 Feb 2012 04:32:03 +0100
+ -- Daniele Tricoli <eriol@mornie.org> Fri, 10 Feb 2012 04:41:11 +0100
diff --git a/debian/rules b/debian/rules
index 8685c5c..adbf8cd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,11 @@ override_dh_auto_build:
$$python setup.py build; \
done
+override_dh_auto_clean:
+ rm -rf build
+ rm -f .coverage
+ dh_auto_clean
+
override_dh_auto_install:
set -ex; \
for python in $(PYVERS); do \