aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2015-12-22 14:15:26 +0000
committerChristopher Baines <mail@cbaines.net>2015-12-22 14:15:26 +0000
commit6b4e166f2475c4be0df7d82dc4d86aa43c6cb066 (patch)
treeeb8f0fa0ed67f14cc5c5645f6bb12494e7966e98 /debian
parentb6983c7c258a0ce3365f7c7409f2a06a8ed70bca (diff)
parent24ae6ba32069ca15f4a163e386964a3accdccf63 (diff)
downloadpython-urllib3-6b4e166f2475c4be0df7d82dc4d86aa43c6cb066.tar
python-urllib3-6b4e166f2475c4be0df7d82dc4d86aa43c6cb066.tar.gz
merge patched into master
Diffstat (limited to 'debian')
-rw-r--r--debian/.git-dpm6
-rw-r--r--debian/patches/01_do-not-use-embedded-python-six.patch51
-rw-r--r--debian/patches/02_require-cert-verification.patch8
-rw-r--r--debian/patches/03_force_setuptools.patch4
-rw-r--r--debian/patches/04_relax_nosetests_options.patch4
-rw-r--r--debian/patches/05_avoid-embedded-ssl-match-hostname.patch13
6 files changed, 45 insertions, 41 deletions
diff --git a/debian/.git-dpm b/debian/.git-dpm
index 2f8c6d5..9f02acc 100644
--- a/debian/.git-dpm
+++ b/debian/.git-dpm
@@ -1,7 +1,7 @@
# see git-dpm(1) from git-dpm package
-842fd4e9f188f13313124e3750f1c768d319fc34
-842fd4e9f188f13313124e3750f1c768d319fc34
-2b3d330a120a16e97cecd5163b5d454dcfe38a2b
+24ae6ba32069ca15f4a163e386964a3accdccf63
+24ae6ba32069ca15f4a163e386964a3accdccf63
+dff63335f212d32d7c1a4bb5276f2d31f5995ea1
dff63335f212d32d7c1a4bb5276f2d31f5995ea1
python-urllib3_1.13.1.orig.tar.gz
1309e9536c74cdad6d5ab089c83235a687b6d7e6
diff --git a/debian/patches/01_do-not-use-embedded-python-six.patch b/debian/patches/01_do-not-use-embedded-python-six.patch
index 225195f..553086b 100644
--- a/debian/patches/01_do-not-use-embedded-python-six.patch
+++ b/debian/patches/01_do-not-use-embedded-python-six.patch
@@ -1,4 +1,4 @@
-From 4e097b776bf499a02b262c722487fcd55c2ee379 Mon Sep 17 00:00:00 2001
+From 39fe68dc64cc8b675bb94892935ef2c8b50f583c Mon Sep 17 00:00:00 2001
From: Daniele Tricoli <eriol@mornie.org>
Date: Thu, 8 Oct 2015 13:19:46 -0700
Subject: Do not use embedded copy of python-six.
@@ -21,15 +21,15 @@ Patch-Name: 01_do-not-use-embedded-python-six.patch
urllib3/filepost.py | 4 ++--
urllib3/response.py | 4 ++--
urllib3/util/request.py | 2 +-
- urllib3/util/response.py | 2 +-
+ urllib3/util/response.py | 3 ++-
urllib3/util/retry.py | 2 +-
- 16 files changed, 18 insertions(+), 18 deletions(-)
+ 16 files changed, 19 insertions(+), 18 deletions(-)
diff --git a/dummyserver/handlers.py b/dummyserver/handlers.py
-index 43398cd..a7828a3 100644
+index fb6f44f..c5ac9b4 100644
--- a/dummyserver/handlers.py
+++ b/dummyserver/handlers.py
-@@ -263,7 +263,7 @@ def _parse_header(line):
+@@ -264,7 +264,7 @@ def _parse_header(line):
"""
import tornado.httputil
import email.utils
@@ -115,10 +115,10 @@ index 421e508..8fcc287 100644
from urllib3.exceptions import (
ConnectTimeoutError,
diff --git a/urllib3/_collections.py b/urllib3/_collections.py
-index b68b9a5..af8074a 100644
+index 67f3ce9..b69ce20 100644
--- a/urllib3/_collections.py
+++ b/urllib3/_collections.py
-@@ -14,7 +14,7 @@ try: # Python 2.7+
+@@ -15,7 +15,7 @@ try: # Python 2.7+
from collections import OrderedDict
except ImportError:
from .packages.ordered_dict import OrderedDict
@@ -128,10 +128,10 @@ index b68b9a5..af8074a 100644
__all__ = ['RecentlyUsedContainer', 'HTTPHeaderDict']
diff --git a/urllib3/connection.py b/urllib3/connection.py
-index 3eab1e2..115eac9 100644
+index 1e4cd41..0075541 100644
--- a/urllib3/connection.py
+++ b/urllib3/connection.py
-@@ -3,7 +3,7 @@ import sys
+@@ -5,7 +5,7 @@ import sys
import socket
from socket import error as SocketError, timeout as SocketTimeout
import warnings
@@ -139,12 +139,12 @@ index 3eab1e2..115eac9 100644
+import six
try: # Python 3
- from http.client import HTTPConnection as _HTTPConnection, HTTPException
+ from http.client import HTTPConnection as _HTTPConnection
diff --git a/urllib3/connectionpool.py b/urllib3/connectionpool.py
-index b38ac68..563f108 100644
+index 995b416..2204b30 100644
--- a/urllib3/connectionpool.py
+++ b/urllib3/connectionpool.py
-@@ -30,7 +30,7 @@ from .exceptions import (
+@@ -31,7 +31,7 @@ from .exceptions import (
NewConnectionError,
)
from .packages.ssl_match_hostname import CertificateError
@@ -154,10 +154,10 @@ index b38ac68..563f108 100644
port_by_scheme,
DummyConnection,
diff --git a/urllib3/fields.py b/urllib3/fields.py
-index c853f8d..5fe3c24 100644
+index c7d4811..2152829 100644
--- a/urllib3/fields.py
+++ b/urllib3/fields.py
-@@ -1,7 +1,7 @@
+@@ -2,7 +2,7 @@ from __future__ import absolute_import
import email.utils
import mimetypes
@@ -167,10 +167,10 @@ index c853f8d..5fe3c24 100644
def guess_content_type(filename, default='application/octet-stream'):
diff --git a/urllib3/filepost.py b/urllib3/filepost.py
-index 0fbf488..97ab970 100644
+index 97a2843..2fea190 100644
--- a/urllib3/filepost.py
+++ b/urllib3/filepost.py
-@@ -3,8 +3,8 @@ import codecs
+@@ -4,8 +4,8 @@ import codecs
from uuid import uuid4
from io import BytesIO
@@ -182,10 +182,10 @@ index 0fbf488..97ab970 100644
writer = codecs.lookup('utf-8')[3]
diff --git a/urllib3/response.py b/urllib3/response.py
-index 788eb6c..c41bd2c 100644
+index 8f2a1b5..e034068 100644
--- a/urllib3/response.py
+++ b/urllib3/response.py
-@@ -7,8 +7,8 @@ from ._collections import HTTPHeaderDict
+@@ -9,8 +9,8 @@ from ._collections import HTTPHeaderDict
from .exceptions import (
ProtocolError, DecodeError, ReadTimeoutError, ResponseNotChunked
)
@@ -197,10 +197,11 @@ index 788eb6c..c41bd2c 100644
from .util.response import is_fp_closed, is_response_to_head
diff --git a/urllib3/util/request.py b/urllib3/util/request.py
-index bc64f6b..5f4ccfd 100644
+index 7377931..40bf0b4 100644
--- a/urllib3/util/request.py
+++ b/urllib3/util/request.py
-@@ -1,6 +1,6 @@
+@@ -1,7 +1,7 @@
+ from __future__ import absolute_import
from base64 import b64encode
-from ..packages.six import b
@@ -209,20 +210,22 @@ index bc64f6b..5f4ccfd 100644
ACCEPT_ENCODING = 'gzip,deflate'
diff --git a/urllib3/util/response.py b/urllib3/util/response.py
-index 2c1de15..6695809 100644
+index bc72327..efb9e04 100644
--- a/urllib3/util/response.py
+++ b/urllib3/util/response.py
-@@ -1,4 +1,4 @@
+@@ -1,5 +1,6 @@
+ from __future__ import absolute_import
-from ..packages.six.moves import http_client as httplib
++
+from six.moves import http_client as httplib
from ..exceptions import HeaderParsingError
diff --git a/urllib3/util/retry.py b/urllib3/util/retry.py
-index 1fb1f23..178b374 100644
+index 03a0124..fd1f5dd 100644
--- a/urllib3/util/retry.py
+++ b/urllib3/util/retry.py
-@@ -8,7 +8,7 @@ from ..exceptions import (
+@@ -9,7 +9,7 @@ from ..exceptions import (
ReadTimeoutError,
ResponseError,
)
diff --git a/debian/patches/02_require-cert-verification.patch b/debian/patches/02_require-cert-verification.patch
index 75d38b6..99f6483 100644
--- a/debian/patches/02_require-cert-verification.patch
+++ b/debian/patches/02_require-cert-verification.patch
@@ -1,4 +1,4 @@
-From 9e59bf6b30776302e6ccd960331a91d073f6a0c3 Mon Sep 17 00:00:00 2001
+From 27ce208c67f4041e8c7e9867236609e522cf06cb Mon Sep 17 00:00:00 2001
From: Jamie Strandboge <jamie@canonical.com>
Date: Thu, 8 Oct 2015 13:19:47 -0700
Subject: require SSL certificate validation by default by using
@@ -14,10 +14,10 @@ Patch-Name: 02_require-cert-verification.patch
1 file changed, 4 insertions(+), 2 deletions(-)
diff --git a/urllib3/connectionpool.py b/urllib3/connectionpool.py
-index 563f108..a99d4ec 100644
+index 2204b30..ef60000 100644
--- a/urllib3/connectionpool.py
+++ b/urllib3/connectionpool.py
-@@ -681,6 +681,8 @@ class HTTPSConnectionPool(HTTPConnectionPool):
+@@ -683,6 +683,8 @@ class HTTPSConnectionPool(HTTPConnectionPool):
``ca_cert_dir``, and ``ssl_version`` are only used if :mod:`ssl` is
available and are fed into :meth:`urllib3.util.ssl_wrap_socket` to upgrade
the connection socket into an SSL socket.
@@ -26,7 +26,7 @@ index 563f108..a99d4ec 100644
"""
scheme = 'https'
-@@ -690,8 +692,8 @@ class HTTPSConnectionPool(HTTPConnectionPool):
+@@ -692,8 +694,8 @@ class HTTPSConnectionPool(HTTPConnectionPool):
strict=False, timeout=Timeout.DEFAULT_TIMEOUT, maxsize=1,
block=False, headers=None, retries=None,
_proxy=None, _proxy_headers=None,
diff --git a/debian/patches/03_force_setuptools.patch b/debian/patches/03_force_setuptools.patch
index 37e1512..4182284 100644
--- a/debian/patches/03_force_setuptools.patch
+++ b/debian/patches/03_force_setuptools.patch
@@ -1,4 +1,4 @@
-From f3ff91a4a00160a0e1afcaa7cd79219cd851bccd Mon Sep 17 00:00:00 2001
+From 32579d35274ade2e68935bb21263b4dc63910ad6 Mon Sep 17 00:00:00 2001
From: Barry Warsaw <barry@debian.org>
Date: Thu, 8 Oct 2015 13:19:49 -0700
Subject: Use setuptools.setup() so that the bdist_wheel
@@ -12,7 +12,7 @@ Patch-Name: 03_force_setuptools.patch
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/setup.py b/setup.py
-index 6bdb7b9..1e1888d 100644
+index 0a2dac3..02d5ec6 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
diff --git a/debian/patches/04_relax_nosetests_options.patch b/debian/patches/04_relax_nosetests_options.patch
index b898d19..a52b940 100644
--- a/debian/patches/04_relax_nosetests_options.patch
+++ b/debian/patches/04_relax_nosetests_options.patch
@@ -1,4 +1,4 @@
-From 28953c4c9c5ad7893bd392658016019fbf78088a Mon Sep 17 00:00:00 2001
+From 11c93ac43225db29b9c7ead00e704ce97a11f89c Mon Sep 17 00:00:00 2001
From: Daniele Tricoli <eriol@mornie.org>
Date: Thu, 8 Oct 2015 13:19:50 -0700
Subject: Do not use logging-clear-handlers to see all logging output and
@@ -14,7 +14,7 @@ Patch-Name: 04_relax_nosetests_options.patch
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/setup.cfg b/setup.cfg
-index 6a64ffa..25a6815 100644
+index b5fe992..ca24a71 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,8 +1,8 @@
diff --git a/debian/patches/05_avoid-embedded-ssl-match-hostname.patch b/debian/patches/05_avoid-embedded-ssl-match-hostname.patch
index 04894d4..1da4d26 100644
--- a/debian/patches/05_avoid-embedded-ssl-match-hostname.patch
+++ b/debian/patches/05_avoid-embedded-ssl-match-hostname.patch
@@ -1,4 +1,4 @@
-From 842fd4e9f188f13313124e3750f1c768d319fc34 Mon Sep 17 00:00:00 2001
+From 24ae6ba32069ca15f4a163e386964a3accdccf63 Mon Sep 17 00:00:00 2001
From: Stefano Rivera <stefanor@debian.org>
Date: Thu, 8 Oct 2015 13:19:51 -0700
Subject: Do not use embedded copy of ssl.match_hostname, when possible
@@ -11,18 +11,17 @@ Last-Update: 2014-11-18
Patch-Name: 05_avoid-embedded-ssl-match-hostname.patch
---
- urllib3/packages/__init__.py | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
+ urllib3/packages/__init__.py | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/urllib3/packages/__init__.py b/urllib3/packages/__init__.py
-index 37e8351..10a3aa8 100644
+index 170e974..35555ed 100644
--- a/urllib3/packages/__init__.py
+++ b/urllib3/packages/__init__.py
-@@ -1,4 +1,9 @@
+@@ -1,5 +1,11 @@
from __future__ import absolute_import
-from . import ssl_match_hostname
--
+try:
+ # cPython >= 2.7.9 has ssl features backported from Python3
+ from ssl import CertificateError
@@ -30,3 +29,5 @@ index 37e8351..10a3aa8 100644
+ import ssl as ssl_match_hostname
+except ImportError:
+ from . import ssl_match_hostname
+
+ __all__ = ('ssl_match_hostname', )