aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2013-05-11 13:08:01 +0000
committerDaniele Tricoli <eriol@mornie.org>2013-05-11 13:08:01 +0000
commit4f088bccff7fb4c9ede9bf77e9275cc73f6716fb (patch)
treed4edd7e1fd148326260480f89b9936925d24a56e /debian
parent59d919ef9ace665df2786b3c7efe44fa334a7ea4 (diff)
downloadpython-urllib3-4f088bccff7fb4c9ede9bf77e9275cc73f6716fb.tar
python-urllib3-4f088bccff7fb4c9ede9bf77e9275cc73f6716fb.tar.gz
Fix syntax error 'unicodeescape' codec can't decode bytes in
position 130-132 for Python3
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/patches/04_relax_nosetests_options.patch4
-rw-r--r--debian/patches/05_fix_python3_syntax_error_in_ntlmpool.patch15
-rw-r--r--debian/patches/series5
4 files changed, 24 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 685fcbe..a7a1a1a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -22,8 +22,11 @@ python-urllib3 (1.6-1) UNRELEASED; urgency=low
- Do not use logging-clear-handlers to see all logging output and
disabled cover-min-percentage since it require python-nose (>= 1.3):
this way it will be easier to backport python-urllib3 to Wheezy.
+ * debian/patches/05_fix_python3_syntax_error_in_ntlmpool.patch
+ - Fix syntax error 'unicodeescape' codec can't decode bytes in
+ position 130-132 for Python3
- -- Daniele Tricoli <eriol@mornie.org> Sat, 11 May 2013 14:24:29 +0200
+ -- Daniele Tricoli <eriol@mornie.org> Sat, 11 May 2013 15:05:07 +0200
python-urllib3 (1.5-1) experimental; urgency=low
diff --git a/debian/patches/04_relax_nosetests_options.patch b/debian/patches/04_relax_nosetests_options.patch
index 5305efa..29f47c6 100644
--- a/debian/patches/04_relax_nosetests_options.patch
+++ b/debian/patches/04_relax_nosetests_options.patch
@@ -15,6 +15,6 @@ Last-Update: 2013-05-11
cover-package = urllib3
-cover-min-percentage = 100
+#cover-min-percentage = 100
-
+
[egg_info]
- tag_build =
+ tag_build =
diff --git a/debian/patches/05_fix_python3_syntax_error_in_ntlmpool.patch b/debian/patches/05_fix_python3_syntax_error_in_ntlmpool.patch
new file mode 100644
index 0000000..7b90098
--- /dev/null
+++ b/debian/patches/05_fix_python3_syntax_error_in_ntlmpool.patch
@@ -0,0 +1,15 @@
+Origin: https://github.com/shazow/urllib3/issues/177
+Description: Fix syntax error 'unicodeescape' codec can't decode bytes in
+ position 130-132 for Python3
+
+--- a/urllib3/contrib/ntlmpool.py
++++ b/urllib3/contrib/ntlmpool.py
+@@ -33,7 +33,7 @@
+ def __init__(self, user, pw, authurl, *args, **kwargs):
+ """
+ authurl is a random URL on the server that is protected by NTLM.
+- user is the Windows user, probably in the DOMAIN\username format.
++ user is the Windows user, probably in the DOMAIN\\username format.
+ pw is the password for the user.
+ """
+ super(NTLMConnectionPool, self).__init__(*args, **kwargs)
diff --git a/debian/patches/series b/debian/patches/series
index c264be2..a8d0b0b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +1,5 @@
-04_relax_nosetests_options.patch
-03_no-setuptools.patch
01_do-not-use-embedded-python-six.patch
02_require-cert-verification.patch
+03_no-setuptools.patch
+04_relax_nosetests_options.patch
+05_fix_python3_syntax_error_in_ntlmpool.patch