aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2013-10-16 20:33:59 +0000
committerDaniele Tricoli <eriol@mornie.org>2013-10-16 20:33:59 +0000
commitafae77d7f10f3ee60dbb8105a2aae77706691c96 (patch)
tree4140925d0edaf001a3124de6f246acdd164e91a9 /debian/rules
parent5137ff5a448b1cb27c2e4105802cb6501a73994f (diff)
downloadpython-urllib3-afae77d7f10f3ee60dbb8105a2aae77706691c96.tar
python-urllib3-afae77d7f10f3ee60dbb8105a2aae77706691c96.tar.gz
Switched to pybuild
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 4 insertions, 21 deletions
diff --git a/debian/rules b/debian/rules
index e2ed423..33e5b40 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,22 +1,16 @@
#!/usr/bin/make -f
export PYTHONWARNINGS=d
+export PYBUILD_DESTDIR_python2=debian/python-urllib3/
+export PYBUILD_DESTDIR_python3=debian/python3-urllib3/
-PYVERS := $(shell pyversions -r)
-PY3VERS := $(shell py3versions -r)
%:
- dh $@ --with python2,python3 --buildsystem=python_distutils
+ dh $@ --with python2,python3 --buildsystem=pybuild
override_dh_auto_configure:
rm -f urllib3/packages/six.py
-override_dh_auto_build:
- set -ex; \
- for python in $(PYVERS) $(PY3VERS); do \
- $$python setup.py build; \
- done
-
override_dh_auto_clean:
rm -rf build
rm -f .coverage
@@ -24,18 +18,7 @@ override_dh_auto_clean:
dh_auto_clean
override_dh_auto_install:
- set -ex; \
- for python in $(PYVERS); do \
- $$python setup.py install --skip-build --root debian/python-urllib3 \
- --install-layout deb; \
- done
-
- set -ex; \
- for python in $(PY3VERS); do \
- $$python setup.py install --skip-build --root debian/python3-urllib3 \
- --install-layout deb; \
- done
-
+ dh_auto_install
# Remove dummyserver/ tests to not pollute namespace.
rm -rf debian/python*-urllib3/usr/lib/python*/dist-packages/dummyserver