aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2014-05-25 01:05:44 +0000
committerDaniele Tricoli <eriol@mornie.org>2014-05-25 01:05:44 +0000
commita83049459ec68bb7eb3d4cb093a1921085c44f45 (patch)
treea4ec2cd2bd82ae1cc25701e169feb6b80fe88269 /debian/rules
parentd37f1c3d270af99f57fe78c4a74aec9192791e78 (diff)
downloadpython-urllib3-a83049459ec68bb7eb3d4cb093a1921085c44f45.tar
python-urllib3-a83049459ec68bb7eb3d4cb093a1921085c44f45.tar.gz
Enabled tests at build time for Python 3
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 11 insertions, 5 deletions
diff --git a/debian/rules b/debian/rules
index f3dea6c..364062f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,8 @@
export PYBUILD_NAME=urllib3
export PYTHONWARNINGS=d
+PYVERS := $(shell pyversions -r)
+PY3VERS := $(shell py3versions -r)
%:
dh $@ --with python2,python3 --buildsystem=pybuild
@@ -20,11 +22,15 @@ override_dh_auto_install:
override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- # Python3 testing is not possible at the moment because missing
- # dependencies: python3-coverage.
- # Upstream is using a python2.7 features: assertRaises() as a context
- # manager
- set -ex; python2.7 /usr/bin/nosetests
+ set -ex; \
+ for python in $(PYVERS); do \
+ $$python setup.py nosetests; \
+ done
+
+ set -ex; \
+ for python in $(PY3VERS); do \
+ $$python setup.py nosetests; \
+ done
endif
override_dh_installchangelogs: