aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2012-02-09 02:48:28 +0000
committerDaniele Tricoli <eriol@mornie.org>2012-02-09 02:48:28 +0000
commit2f76a5750b1a14a7090a21ead1df36ced1342733 (patch)
treea1ec52bea492318f210fa56f7346a1e015fd2883 /debian/rules
parentf7dcb46527a3f103ced8bc08677457e0b34e11fc (diff)
downloadpython-urllib3-2f76a5750b1a14a7090a21ead1df36ced1342733.tar
python-urllib3-2f76a5750b1a14a7090a21ead1df36ced1342733.tar.gz
Enabled testing at build time
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 511f2a9..8685c5c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,7 @@
#!/usr/bin/make -f
+export PYTHONWARNINGS=d
+
PYVERS := $(shell pyversions -r)
PY3VERS := $(shell py3versions -r)
@@ -25,5 +27,18 @@ override_dh_auto_install:
--install-layout deb; \
done
+ # Remove dummyserver/ tests to not pollute namespace.
+ rm -rf debian/python*-urllib3/usr/lib/python*/dist-packages/dummyserver
+
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+ # Python3 testing is not possible at the moment because missing
+ # dependencies: python3-coverage and python3-tornado.
+ set -ex; \
+ for python in $(PYVERS); do \
+ $$python /usr/bin/nosetests; \
+ done
+endif
+
override_dh_installchangelogs:
dh_installchangelogs CHANGES.rst