aboutsummaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2012-11-09 03:16:33 +0000
committerDaniele Tricoli <eriol@mornie.org>2012-11-09 03:16:33 +0000
commit052e218269d5b318da94b94e36204a4229a61a84 (patch)
treecede931d1a95de337a11e7f4ea280a788aa2eed3 /debian/rules
parenta1e3ebdf80fa969017f7197933e160b62b132966 (diff)
downloadpython-urllib3-052e218269d5b318da94b94e36204a4229a61a84.tar
python-urllib3-052e218269d5b318da94b94e36204a4229a61a84.tar.gz
Run tests only for python2.7 since upstream is using assertRaises() as a context manager
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 3 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 6207fb9..e2ed423 100755
--- a/debian/rules
+++ b/debian/rules
@@ -43,10 +43,9 @@ override_dh_auto_test:
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
# Python3 testing is not possible at the moment because missing
# dependencies: python3-coverage.
- set -ex; \
- for python in $(PYVERS); do \
- $$python /usr/bin/nosetests; \
- done
+ # Upstream is using a python2.7 features: assertRaises() as a context
+ # manager
+ set -ex; python2.7 /usr/bin/nosetests
endif
override_dh_installchangelogs: