aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2013-05-10 03:36:32 +0000
committerDaniele Tricoli <eriol@mornie.org>2013-05-10 03:36:32 +0000
commite60e123dc16866c6f9f210783565c709a7d64885 (patch)
treee065c005a487569e285ae8ad26f7be6447c1003a /debian/patches
parent249ef838f35a436216a1abdc04d36c4e8da9e441 (diff)
downloadpython-urllib3-e60e123dc16866c6f9f210783565c709a7d64885.tar
python-urllib3-e60e123dc16866c6f9f210783565c709a7d64885.tar.gz
Do not use setuptools
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/03_no-setuptools.patch26
-rw-r--r--debian/patches/series1
2 files changed, 27 insertions, 0 deletions
diff --git a/debian/patches/03_no-setuptools.patch b/debian/patches/03_no-setuptools.patch
new file mode 100644
index 0000000..ee2e913
--- /dev/null
+++ b/debian/patches/03_no-setuptools.patch
@@ -0,0 +1,26 @@
+Description: Do not use setuptools.
+Author: Daniele Tricoli <eriol@mornie.org>
+Forwarded: not-needed
+Last-Update: 2013-05-10
+
+--- a/setup.py
++++ b/setup.py
+@@ -5,11 +5,6 @@
+ import os
+ import re
+
+-try:
+- import setuptools
+-except ImportError:
+- pass # No 'develop' command, oh well.
+-
+ base_path = os.path.dirname(__file__)
+
+ # Get the version (borrowed from SQLAlchemy)
+@@ -49,6 +44,4 @@
+ 'urllib3.contrib',
+ ],
+ requires=requirements,
+- tests_require=tests_requirements,
+- test_suite='test',
+ )
diff --git a/debian/patches/series b/debian/patches/series
index cb492ff..47bcce3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
+03_no-setuptools.patch
01_do-not-use-embedded-python-six.patch
02_require-cert-verification.patch