aboutsummaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorBarry Warsaw <barry@debian.org>2014-05-13 01:15:29 +0000
committerBarry Warsaw <barry@debian.org>2014-05-13 01:15:29 +0000
commit4278e068e0caa2c010b2b6c8765b1b6b2657c770 (patch)
tree6b704217e6c1857d07a1c51ac208a44e209dfa3b /debian/patches
parent5eef2dd62a1481f5874f6a8f7721cf22b1e6f293 (diff)
downloadpython-urllib3-4278e068e0caa2c010b2b6c8765b1b6b2657c770.tar
python-urllib3-4278e068e0caa2c010b2b6c8765b1b6b2657c770.tar.gz
* d/control:
- Added python-setuptools, python3-setuptools, and python3-wheel to Build-Depends. - Added python-urllib3-wheels binary package. * d/rules: - Build the universal wheels. - Simplify through use of PYBUILD_NAME. * d/python-urllib3-wheels.install: Added. * d/patches/setuptools.patch: Use setuptools.setup() so that the bdist_wheel command will work.
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/setuptools.patch10
2 files changed, 11 insertions, 0 deletions
diff --git a/debian/patches/series b/debian/patches/series
index e276627..52e03c4 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,4 @@
02_require-cert-verification.patch
03_no-setuptools.patch
04_relax_nosetests_options.patch
+setuptools.patch
diff --git a/debian/patches/setuptools.patch b/debian/patches/setuptools.patch
new file mode 100644
index 0000000..ff8f7e9
--- /dev/null
+++ b/debian/patches/setuptools.patch
@@ -0,0 +1,10 @@
+--- a/setup.py
++++ b/setup.py
+@@ -1,6 +1,6 @@
+ #!/usr/bin/env python
+
+-from distutils.core import setup
++from setuptools import setup
+
+ import os
+ import re