aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/01_do-not-use-embedded-python-six.patch
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2012-04-17 19:11:21 +0000
committerDaniele Tricoli <eriol@mornie.org>2012-04-17 19:11:21 +0000
commit37f9440d34eca70cba09a144f9612c6631c4d74c (patch)
treee6a0a9be06cf6c08052f56795e0fad6785503230 /debian/patches/01_do-not-use-embedded-python-six.patch
parentc8f902bb8ac387a5a02559895dac54aeafff0849 (diff)
downloadpython-urllib3-37f9440d34eca70cba09a144f9612c6631c4d74c.tar
python-urllib3-37f9440d34eca70cba09a144f9612c6631c4d74c.tar.gz
* debian/patches/01_do-not-use-embedded-python-six.patch
- Refreshed * debian/rules - Actually remove the embedded python-six from binary packages
Diffstat (limited to 'debian/patches/01_do-not-use-embedded-python-six.patch')
-rw-r--r--debian/patches/01_do-not-use-embedded-python-six.patch45
1 files changed, 28 insertions, 17 deletions
diff --git a/debian/patches/01_do-not-use-embedded-python-six.patch b/debian/patches/01_do-not-use-embedded-python-six.patch
index f2fa877..6729f1d 100644
--- a/debian/patches/01_do-not-use-embedded-python-six.patch
+++ b/debian/patches/01_do-not-use-embedded-python-six.patch
@@ -1,62 +1,73 @@
Description: Do not use embedded copy of python-six.
Author: Daniele Tricoli <eriol@mornie.org>
Forwarded: not-needed
-Last-Update: 2012-03-29
+Last-Update: 2012-04-17
--- a/test/test_collections.py
+++ b/test/test_collections.py
@@ -1,7 +1,7 @@
import unittest
-
+
from urllib3._collections import RecentlyUsedContainer as Container
-from urllib3.packages import six
+import six
xrange = six.moves.xrange
-
-
+
+
--- a/urllib3/connectionpool.py
+++ b/urllib3/connectionpool.py
@@ -51,7 +51,7 @@
)
-
+
from .packages.ssl_match_hostname import match_hostname, CertificateError
-from .packages import six
+import six
-
-
+
+
xrange = six.moves.xrange
--- a/urllib3/filepost.py
+++ b/urllib3/filepost.py
@@ -14,8 +14,8 @@
-
+
from io import BytesIO
-
+
-from .packages import six
-from .packages.six import b
+import six
+from six import b
-
+
writer = codecs.lookup('utf-8')[3]
-
+
--- a/urllib3/response.py
+++ b/urllib3/response.py
@@ -11,7 +11,7 @@
from io import BytesIO
-
+
from .exceptions import HTTPError
-from .packages.six import string_types as basestring
+from six import string_types as basestring
-
-
+
+
log = logging.getLogger(__name__)
--- a/urllib3/util.py
+++ b/urllib3/util.py
@@ -16,7 +16,7 @@
except ImportError: # `select` doesn't exist on AppEngine.
select = False
-
+
-from .packages import six
+import six
from .exceptions import LocationParseError
-
-
+
+
+--- a/test/test_filepost.py
++++ b/test/test_filepost.py
+@@ -1,7 +1,7 @@
+ import unittest
+
+ from urllib3.filepost import encode_multipart_formdata, iter_fields
+-from urllib3.packages.six import b, u
++from six import b, u
+
+
+ BOUNDARY = '!! test boundary !!'