aboutsummaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
authorDaniele Tricoli <eriol@mornie.org>2012-02-06 11:31:44 +0000
committerDaniele Tricoli <eriol@mornie.org>2012-02-06 11:31:44 +0000
commitc3d8504ad9bcdb6980302825167b3606d64a94cf (patch)
treec406f6ab5c754fdd3ce400bfeb1f724eb42e6443 /debian/control
parentb9b90ae1e48f3ee9a7bc9ffe39b6b523ca25731f (diff)
downloadpython-urllib3-c3d8504ad9bcdb6980302825167b3606d64a94cf.tar
python-urllib3-c3d8504ad9bcdb6980302825167b3606d64a94cf.tar.gz
Build Python 3 package
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control22
1 files changed, 21 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index cb123a2..6d8ff0f 100644
--- a/debian/control
+++ b/debian/control
@@ -7,8 +7,10 @@ Build-Depends:
debhelper (>= 7.0.50~),
python-all (>= 2.6.6-3),
python-setuptools (>= 0.6b3),
+ python3-all
Standards-Version: 3.9.2
X-Python-Version: >= 2.6
+X-Python3-Version: >= 3.0
Homepage: http://urllib3.readthedocs.org
Vcs-Svn: svn://svn.debian.org/python-modules/packages/python-urllib3/trunk/
Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/python-urllib3/trunk/
@@ -16,7 +18,7 @@ Vcs-Browser: http://svn.debian.org/viewsvn/python-modules/packages/python-urllib
Package: python-urllib3
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}
-Description: Python HTTP library with thread-safe connection pooling, file post and more
+Description: HTTP library with thread-safe connection pooling for Python
urllib3 supports features left out of urllib and urllib2 libraries.
.
- Re-use the same socket connection for multiple requests (HTTPConnectionPool
@@ -28,3 +30,21 @@ Description: Python HTTP library with thread-safe connection pooling, file post
- Thread-safe and sanity-safe.
- Small and easy to understand codebase perfect for extending and
building upon.
+
+Package: python3-urllib3
+Architecture: all
+Depends: ${misc:Depends}, ${python:Depends}
+Description: HTTP library with thread-safe connection pooling for Python3
+ urllib3 supports features left out of urllib and urllib2 libraries.
+ .
+ - Re-use the same socket connection for multiple requests (HTTPConnectionPool
+ and HTTPSConnectionPool) (with optional client-side certificate
+ verification).
+ - File posting (encode_multipart_formdata).
+ - Built-in redirection and retries (optional).
+ - Supports gzip and deflate decoding.
+ - Thread-safe and sanity-safe.
+ - Small and easy to understand codebase perfect for extending and
+ building upon.
+ .
+ This package contains the Python 3 version of the library.