aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/02_use-system-chardet-and-urllib3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/02_use-system-chardet-and-urllib3.patch')
-rw-r--r--debian/patches/02_use-system-chardet-and-urllib3.patch9
1 files changed, 5 insertions, 4 deletions
diff --git a/debian/patches/02_use-system-chardet-and-urllib3.patch b/debian/patches/02_use-system-chardet-and-urllib3.patch
index 327d7b5..54df371 100644
--- a/debian/patches/02_use-system-chardet-and-urllib3.patch
+++ b/debian/patches/02_use-system-chardet-and-urllib3.patch
@@ -18,7 +18,7 @@ Last-Update: 2014-01-27
+from urllib3.util import Timeout as TimeoutSauce
from .compat import urlparse, basestring, urldefrag, unquote
from .utils import (DEFAULT_CA_BUNDLE_PATH, get_encoding_from_headers,
- except_on_missing_scheme, get_auth_from_url)
+ prepend_scheme_if_needed, get_auth_from_url)
from .structures import CaseInsensitiveDict
-from .packages.urllib3.exceptions import MaxRetryError
-from .packages.urllib3.exceptions import TimeoutError
@@ -55,7 +55,7 @@ Last-Update: 2014-01-27
builtin_str = str
--- a/requests/models.py
+++ b/requests/models.py
-@@ -17,10 +17,10 @@
+@@ -16,10 +16,10 @@
from .auth import HTTPBasicAuth
from .cookies import cookiejar_from_dict, get_cookie_header
@@ -72,7 +72,7 @@ Last-Update: 2014-01-27
ChunkedEncodingError, ContentDecodingError)
--- a/setup.py
+++ b/setup.py
-@@ -16,12 +16,6 @@
+@@ -16,13 +16,6 @@
packages = [
'requests',
@@ -81,7 +81,8 @@ Last-Update: 2014-01-27
- 'requests.packages.urllib3',
- 'requests.packages.urllib3.packages',
- 'requests.packages.urllib3.contrib',
-- 'requests.packages.urllib3.packages.ssl_match_hostname'
+- 'requests.packages.urllib3.util',
+- 'requests.packages.urllib3.packages.ssl_match_hostname',
]
requires = []