aboutsummaryrefslogtreecommitdiff
path: root/debian/patches/02_use-system-chardet-and-urllib3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/02_use-system-chardet-and-urllib3.patch')
-rw-r--r--debian/patches/02_use-system-chardet-and-urllib3.patch33
1 files changed, 23 insertions, 10 deletions
diff --git a/debian/patches/02_use-system-chardet-and-urllib3.patch b/debian/patches/02_use-system-chardet-and-urllib3.patch
index 8836c47..956ffb8 100644
--- a/debian/patches/02_use-system-chardet-and-urllib3.patch
+++ b/debian/patches/02_use-system-chardet-and-urllib3.patch
@@ -3,22 +3,22 @@ Description: Use the system python-chardet and python-urllib3 instead of the
used to supply a stub for ``requests.packages.urllib3``.
Author: Daniele Tricoli <eriol@mornie.org>
Forwarded: not-needed
-Last-Update: 2014-10-21
+Last-Update: 2015-05-04
--- a/requests/adapters.py
+++ b/requests/adapters.py
-@@ -11,21 +11,21 @@
+@@ -11,22 +11,22 @@
import socket
from .models import Response
--from .packages.urllib3 import Retry
-from .packages.urllib3.poolmanager import PoolManager, proxy_from_url
-from .packages.urllib3.response import HTTPResponse
-from .packages.urllib3.util import Timeout as TimeoutSauce
-+from urllib3 import Retry
+-from .packages.urllib3.util.retry import Retry
+from urllib3.poolmanager import PoolManager, proxy_from_url
+from urllib3.response import HTTPResponse
+from urllib3.util import Timeout as TimeoutSauce
++from urllib3.util.retry import Retry
from .compat import urlparse, basestring
from .utils import (DEFAULT_CA_BUNDLE_PATH, get_encoding_from_headers,
prepend_scheme_if_needed, get_auth_from_url, urldefragauth)
@@ -30,6 +30,7 @@ Last-Update: 2014-10-21
-from .packages.urllib3.exceptions import ProtocolError
-from .packages.urllib3.exceptions import ReadTimeoutError
-from .packages.urllib3.exceptions import SSLError as _SSLError
+-from .packages.urllib3.exceptions import ResponseError
+from urllib3.exceptions import ConnectTimeoutError
+from urllib3.exceptions import HTTPError as _HTTPError
+from urllib3.exceptions import MaxRetryError
@@ -37,9 +38,10 @@ Last-Update: 2014-10-21
+from urllib3.exceptions import ProtocolError
+from urllib3.exceptions import ReadTimeoutError
+from urllib3.exceptions import SSLError as _SSLError
++from urllib3.exceptions import ResponseError
from .cookies import extract_cookies_to_jar
from .exceptions import (ConnectionError, ConnectTimeout, ReadTimeout, SSLError,
- ProxyError)
+ ProxyError, RetryError)
--- a/requests/compat.py
+++ b/requests/compat.py
@@ -4,7 +4,7 @@
@@ -51,7 +53,7 @@ Last-Update: 2014-10-21
import sys
-@@ -91,7 +91,7 @@
+@@ -39,7 +39,7 @@
import cookielib
from Cookie import Morsel
from StringIO import StringIO
@@ -65,7 +67,7 @@ Last-Update: 2014-10-21
@@ -16,10 +16,10 @@
from .auth import HTTPBasicAuth
- from .cookies import cookiejar_from_dict, get_cookie_header
+ from .cookies import cookiejar_from_dict, get_cookie_header, _copy_cookie_jar
-from .packages.urllib3.fields import RequestField
-from .packages.urllib3.filepost import encode_multipart_formdata
-from .packages.urllib3.util import parse_url
@@ -74,12 +76,12 @@ Last-Update: 2014-10-21
+from urllib3.filepost import encode_multipart_formdata
+from urllib3.util import parse_url
+from urllib3.exceptions import (
- DecodeError, ReadTimeoutError, ProtocolError)
+ DecodeError, ReadTimeoutError, ProtocolError, LocationParseError)
from .exceptions import (
- HTTPError, RequestException, MissingSchema, InvalidURL,
+ HTTPError, MissingSchema, InvalidURL, ChunkedEncodingError,
--- a/setup.py
+++ b/setup.py
-@@ -19,12 +19,6 @@
+@@ -18,12 +18,6 @@
packages = [
'requests',
'requests.packages',
@@ -114,3 +116,14 @@ Last-Update: 2014-10-21
class RequestException(IOError):
+--- a/requests/sessions.py
++++ b/requests/sessions.py
+@@ -21,7 +21,7 @@
+ from .utils import to_key_val_list, default_headers, to_native_string
+ from .exceptions import (
+ TooManyRedirects, InvalidSchema, ChunkedEncodingError, ContentDecodingError)
+-from .packages.urllib3._collections import RecentlyUsedContainer
++from urllib3._collections import RecentlyUsedContainer
+ from .structures import CaseInsensitiveDict
+
+ from .adapters import HTTPAdapter